Bug 428291 - GFS2: Reduce gfs2 memory requirements
GFS2: Reduce gfs2 memory requirements
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Don Zickus
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-10 10:37 EST by Robert Peterson
Modified: 2008-05-21 11:06 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:06:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the problem (11.12 KB, patch)
2008-01-10 11:08 EST, Robert Peterson
no flags Details | Diff

  None (edit)
Description Robert Peterson 2008-01-10 10:37:38 EST
Description of problem:
GFS2 uses too much memory.  For every buffer, gfs2 has a special
lock structure called a glock, due to the type of page-level locking
it does.  Right now, GFS2 allocates an inode structure to keep track
of the address space associated with metadata.  We need to reduce the
memory requirements.  We can do this by making it only allocate the
address space inode when it's needed, on the fly.  That reduces the
size of each glock considerably.

Version-Release number of selected component (if applicable):
RHEL5.2

How reproducible:
Always

Steps to Reproduce:
1. Run any program that does a lot of writing
  
Actual results:
Lots of memory allocated per page.

Expected results:
Less memory allocated.

Additional info:
There is an upstream patch to do this that needs to be crosswritten
for RHEL5.
Comment 1 Robert Peterson 2008-01-10 11:08:06 EST
Created attachment 291295 [details]
Patch to fix the problem

Here is the patch I'll be posting to rhkernel-list.
Comment 2 Robert Peterson 2008-01-10 11:20:47 EST
Patch compiled and tested on "kool", and posted to rhkernel-list.
Setting status to modified and rerouting to Don Zickus.
Comment 3 Don Zickus 2008-01-21 12:30:33 EST
in 2.6.18-71.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 6 errata-xmlrpc 2008-05-21 11:06:08 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.