Bug 428302 - GDM claims X Keeps Crashing but X works from startx
Summary: GDM claims X Keeps Crashing but X works from startx
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
(Show other bugs)
Version: 8
Hardware: x86_64 Linux
low
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-10 17:23 UTC by Andrew McNabb
Modified: 2008-05-14 15:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 15:53:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew McNabb 2008-01-10 17:23:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
GDM won't start.  After starting the X server 3 times, it gives the X Keeps Crashing message.  At each of the 3 attempts, X quits within a second of the X mouse cursor appearing.  Otherwise, X seems to work just fine (i.e., a user can run startx).  This is with the binary nvidia driver.

Version-Release number of selected component (if applicable):
gdm-2.20.2-2

How reproducible:
Always


Steps to Reproduce:
1. install nvidia driver
2. start gdm or reboot

Actual Results:
Mouse cursor appears, then X quits.  This happens 3 times before the X Keeps Crashing error appears.

Expected Results:
GDM login window should appear.

Additional info:
The problem doesn't seem to be with X for a few reasons.  First, X displays the mouse cursor before quitting.  Second, no error messages appear in /var/log/Xorg.0.log.  Third, if a user logs in and runs startx, the X session starts up properly.

This only seems to happen with the binary nvidia driver and not with nv.

Comment 1 Andrew McNabb 2008-01-10 17:29:14 UTC
I install xorg-x11-xdm.  Using xdm instead of gdm seems to be a temporary
workaround, since xdm seems to work fine.

Comment 2 Andrew McNabb 2008-04-10 21:18:27 UTC
It looks like gdm works again now after some recent updates.


Note You need to log in before you can comment on or make changes to this bug.