Bug 428308 - New ati driver in rawhide causes X to crash at start
New ati driver in rawhide causes X to crash at start
Status: CLOSED DUPLICATE of bug 428813
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-01-10 13:06 EST by Robin Norwood
Modified: 2008-01-24 19:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-24 19:29:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xorg log of the crash (5.64 KB, text/plain)
2008-01-10 13:06 EST, Robin Norwood
no flags Details
log of the new crash (32.46 KB, text/plain)
2008-01-11 21:28 EST, Robin Norwood
no flags Details
Me too Xorg.0.log (35.83 KB, text/plain)
2008-01-23 11:18 EST, Matěj Cepl
no flags Details

  None (edit)
Description Robin Norwood 2008-01-10 13:06:17 EST
o Installed new F8 on T43 laptop
o Updated to latest rawhide
o Reboot
o No X.

The interesting parts of the xorg log look like this:

(II) LoadModule: "radeon"

(II) Loading /usr/lib/xorg/modules/drivers//radeon_drv.so
(II) Module radeon: vendor="X.Org Foundation"
        compiled for, module version = 4.3.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 3.0
(EE) module ABI major version (3) doesn't match the server's version (4)
(II) UnloadModule: "radeon"
(II) Unloading /usr/lib/xorg/modules/drivers//radeon_drv.so
(EE) Failed to load module "radeon" (module requirement mismatch, 0)

But I'll attach the entire log also.

The vesa driver seems to work.

ATI driver is the latest rawhide one:


And the video chip is:

01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]
Comment 1 Robin Norwood 2008-01-10 13:06:17 EST
Created attachment 291303 [details]
xorg log of the crash
Comment 2 Robin Norwood 2008-01-11 21:27:46 EST
fwiw, the even newer ATI driver is even worse.  Now, X crashes at startup with a
corrupt display, except for the mouse pointer, which looks and works fine.
Keyboard seems nonresponsive - Ctrl-Alt-Backspace won't kill X, and switching to
VTs doesn't work either.

[rnorwood@solitude ~]$ rpm -q xorg-x11-drv-ati

This happens when the driver is set to ati, radeon (not sure which one is right
these days for this card), if no xorg.conf is used, or with system-config-display.
Comment 3 Robin Norwood 2008-01-11 21:28:29 EST
Created attachment 291444 [details]
log of the new crash
Comment 4 Robin Norwood 2008-01-11 21:29:55 EST
vesa driver still works fine, by the by.
Comment 5 Matěj Cepl 2008-01-23 11:18:46 EST
Created attachment 292663 [details]
Me too Xorg.0.log

Thanks, Robin, your advice to use vesa saved me. Otherwise nothing else works
here. I can confirm that I can fully reproduce here, first when I used older
kernel kernel- X would work, but after today's upgrade,
there is no hope. And the errors looks pretty similar:

[matej@hubmaier ~]$ grep '(EE)' /tmp/Xorg.0.log 
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) Unable to locate/open config file
(EE) module ABI major version (1) doesn't match the server's version (4)
(EE) Failed to load module "vga" (module requirement mismatch, 0)
(EE) open /dev/fb0: No such file or directory
[matej@hubmaier ~]$ 

Used packages:
[matej@hubmaier ~]$ rpm -q kernel xorg-x11-drv-ati xorg-x11-server-Xorg
[matej@hubmaier ~]
Comment 6 Matěj Cepl 2008-01-23 11:21:28 EST
Actually, Xorg doesn't crash, it just goes to 100% CPU (or close to 100%) and
nothing (not even kill -9) is able to stop it.
Comment 7 Matěj Cepl 2008-01-23 16:31:29 EST
Robin, does renaming /usr/lib/xorg/modules/extensions/libdri.so to something
nonsensical helps? If yes, I think we are talking about duplicate of bug 428813.
Comment 8 Robin Norwood 2008-01-24 11:59:27 EST
Yeah - I:

o Update to latest rawhide as of today, giving me these packages:

[rnorwood@solitude ~]$ rpm -q kernel xorg-x11-drv-ati xorg-x11-server-Xorg

o Moved aside my modified xorg.conf (which specified 'vesa')
o Ran system-config-display
  - Corrupt display, locked up X
o Had to power off and back on
o Moved aside libdri.so
o Re-ran system-config-display
o X works (with the radeon driver)

So, this is probably a dupe of 428813.

Comment 9 Robin Norwood 2008-01-24 12:00:02 EST
(btw, kernel-2.6.24-0.167 was the running one)
Comment 10 Matěj Cepl 2008-01-24 19:29:11 EST
(In reply to comment #8)
> o Re-ran system-config-display

In the new stateless world, you even don't have to run system-config-display.
Just mv /etc/X11/xorg.conf{,.backup} and then restart X.

But, yes closing as duplicate.

*** This bug has been marked as a duplicate of 428813 ***

Note You need to log in before you can comment on or make changes to this bug.