Bug 428347 - stops with File exists: '/home/pungi/repodata-i386'
stops with File exists: '/home/pungi/repodata-i386'
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-10 18:33 EST by Patrice Dumas
Modified: 2013-01-09 20:46 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 16:30:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pungi log (1.36 MB, text/plain)
2008-01-10 18:34 EST, Patrice Dumas
no flags Details
kickstart file (1.35 KB, text/plain)
2008-01-10 18:35 EST, Patrice Dumas
no flags Details

  None (edit)
Description Patrice Dumas 2008-01-10 18:33:21 EST
Description of problem:

I am trying to use pungi, but it stops with:
Pungi.Pungi:INFO: Running /usr/bin/createrepo --quiet --database --groupfile
/home/pungi/work/i386/Fedora-20080110-comps.xml --cachedir
/var/cache/pungi/createrepocache --baseurl media://1200007468.811834 --outputdir
/home/pungi/20080110/i386/os-disc1 --basedir /home/pungi/20080110/i386/os
/home/pungi/20080110/i386/os
Pungi.Pungi:INFO: Creating media repo file.
Traceback (most recent call last):
  File "/usr/bin/pungi", line 188, in <module>
    main()
  File "/usr/bin/pungi", line 101, in main
    mypungi.doCreateIsos(split=opts.nosplitmedia)
  File "/usr/lib/python2.5/site-packages/pypungi/pungi.py", line 444, in
doCreateIsos
    'repodata-%s' % self.config.get('default', 'arch')))
  File "/usr/lib/python2.5/shutil.py", line 196, in move
    copytree(src, dst, symlinks=True)
  File "/usr/lib/python2.5/shutil.py", line 110, in copytree
    os.makedirs(dst)
  File "/usr/lib/python2.5/os.py", line 172, in makedirs
    mkdir(name, mode)
OSError: [Errno 17] File exists: '/home/pungi/repodata-i386'

I started it like that:
pungi -c pl-fedora.ks --nosource --force


I'll try to remove the files by hand and see if the issue is
still there.

Version-Release number of selected component (if applicable):
pungi-1.2.6-1.fc9


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2008-01-10 18:34:38 EST
Created attachment 291338 [details]
pungi log
Comment 2 Patrice Dumas 2008-01-10 18:35:14 EST
Created attachment 291339 [details]
kickstart file
Comment 3 Patrice Dumas 2008-01-10 19:30:40 EST
I can confirm that after I removed the repo directory that was in the
directory it proceeds.
Comment 4 Jesse Keating 2008-02-28 16:30:57 EST
I think I fixed this with a commit I made upstream.  We'll see in next release.

Note You need to log in before you can comment on or make changes to this bug.