Bug 428351 - Missing requires in sabayon-apply
Summary: Missing requires in sabayon-apply
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: sabayon   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-10 23:43 UTC by Kostas Georgiou
Modified: 2015-03-03 22:31 UTC (History)
1 user (show)

Fixed In Version: sabayon-2.20.1-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 15:01:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kostas Georgiou 2008-01-10 23:43:15 UTC
The postinst script in the xguest rpm fails with the following error:
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.5/site-packages/sabayon/userdb.py", line 23, in <module>
    import libxml2
ImportError: No module named libxml2

A dependency on libxml2-python should be enough to fix the problem.

Comment 1 Tomáš Bžatek 2008-02-22 14:30:18 UTC
Reassigning to dwalsh as he's the owner of xguest package, changing Component
from sabayon to xguest

Comment 2 Daniel Walsh 2008-02-22 14:48:06 UTC
xguest has

Requires(post): sabayon-apply

And sabayon-apply requires 

libxml-python

So this is definitely a sabayon spec file problem.

Comment 3 Fedora Update System 2008-02-22 16:15:25 UTC
sabayon-2.20.1-6.fc8 has been submitted as an update for Fedora 8

Comment 4 Fedora Update System 2008-02-26 00:22:38 UTC
sabayon-2.20.1-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.