Bug 428362 - Configure VPN page doesn't work in NetworkManager-openvpn
Configure VPN page doesn't work in NetworkManager-openvpn
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Niemueller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-10 19:53 EST by Andrew McNabb
Modified: 2008-01-19 05:20 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 12:56:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew McNabb 2008-01-10 19:53:26 EST
Description of problem:

The OpenVPN configuration screen in the NetworkManager applet doesn't work
right.  There seem to be a few problems.

First, clicking on "Advanced" doesn't do anything.

Second, "Import Saved Configuration" brings up a file browsing window, and after
selecting a file, the browsing window closes but nothing else happens.  It
doesn't even give any error messages if a random text files is selected.

Third, it seems that NetworkManager-openvpn doesn't allow for an openvpn.conf
file to be specified.  As a sysadmin, I'm used to distributing an openvpn.conf
file with keys, and the user runs "openvpn --config openvpn.conf".  Since the
NetworkManager-openvpn configuration screens don't support all possible options,
they should probably at least allow a config file to be specified.

Version-Release number of selected component (if applicable):
NetworkManager-openvpn.ppc 1:0.7.0-2.svn3047.fc8

How reproducible:
Configure a new VPN Connection in the NetworkManager applet.

Steps to Reproduce:
1. NetworkManager Applet: "VPN Connections": "Configure VPN": "Add"
2. at "Create VPN Connection1 of 2", select OpenVPN Client
3. at "Create VPN Connection2 of 2", click on "Advanced" or "Import Saved
Configuration"
  
Actual results:

For "Advanced", nothing at all happens.  For "Import Saved Configuration", a
browsing window pops up, but once a file is selected, it comes back to the
"Create VPN Connection2 of 2" screen but nothing else happens.

Expected results:

"Advanced" should pop up another window or change the current window.

"Import Saved Configuration" should either give an error message if an invalid
file is given or do something if a proper one is given.

Additional info:

Thanks!
Comment 1 Tim Niemueller 2008-01-14 04:42:17 EST
Please ugprade to the newest version currently in updates-testing. This should
fix the first problem.

For the second problem I snooped on the third one: did you try to open the
openvpn.conf file? This is not supported. Rather it uses a ini-style config file
which can be exported from the config page of an existing VPN connection.

The third thing is not supported and is not considered to be a good choice to
support. Rather we support the mentioned ini-style config files. One thing that
could be considered would be to add openvpn.conf import support, feel free to
supply a patch.
Comment 2 Andrew McNabb 2008-01-14 11:11:19 EST
Thanks for your response.

For the first issue, I have not tried the latest version in updates-testing. 
For now, I will assume that the fix works.

For the second issue, I did indeed try to open an openvpn.conf file.  Shouldn't
it have thrown an error message rather than failing silently?  I think that's a bug.

For the third issue, I would like a bit more information before being completely
satisfied.  OpenVPN can't import the ini-style files, can it?  I really need a
single file that has cross-platform support.  For system administration
purposes, I need to be able to distribute a single file that behaves the same on
Linux, Mac OS, and Windows.  My understanding was that an openvpn.conf was the
only way to do this.

Thanks!
Comment 3 Tim Niemueller 2008-01-14 11:21:03 EST
2.: I just read a file with no settings, since there was no appropriate section
in the file and so it just skipped the rest. We should probably raise a warning
if this section is missing and there is no setting at all or if not the
minimally required settings are in the file.

3.: The ini-style approach exists because this was ported from the vpnc plugin
and it was already available. If you feel the need for openvpn.conf support
please go ahead and send a patch with that feature. It's not in there yet and
unfortunately I do not have the time in the near future to implement it.
Comment 4 Tim Niemueller 2008-01-18 12:56:19 EST
Closing this now as the bug from 1. has been fixed already.
Comment 5 Tim Niemueller 2008-01-19 05:20:48 EST
For 2. see #375081
3. is a feature request which I can't do myself atm. Patches welcome.

Note You need to log in before you can comment on or make changes to this bug.