Bug 428413 - Review Request: Freemind - Mind mapping tool
Review Request: Freemind - Mind mapping tool
Status: CLOSED DUPLICATE of bug 638590
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2008-01-11 06:06 EST by Alec Leamas
Modified: 2013-05-27 06:12 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 17:32:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alec Leamas 2008-01-11 06:06:52 EST
Spec URL: /home/mk/src/rpms/srpms/freemind-0.9.0-0.Beta_15_icon_butterfly.1.src.rpm
SRPM URL: http://hem.bredband.net/miko22/freemind-0.9.0-0.Beta_15_icon_butterfly.1.src.rpm
Description: 
FreeMind is an open source mind mapping software that enables you to
visualize ideas, projects, concepts, brainstorming, research or any
other task that can benefit from a structured overview. The software
consists of a desktop java program to create mindmaps, and a java
applet for publishing mindmaps on the net.
Comment 1 Alec Leamas 2008-01-11 06:17:20 EST
This is my first attempt to provide a package for Fedora...

Also, it's a java application. There is an obvious need for guidelines for java
apps, hav'nt found any. OTOH, this app was one of twenty good OS apps picked by
a Swedish newspaper for general use, so it might make sense to include it.

The spec URL is (obviously) wrong. Should be:
http://hem.bredband.net/miko22/freemind.spec
Comment 2 Alec Leamas 2008-01-12 08:53:11 EST
Trying to do my homework. Reviewed #428410, made some remarks on #428435,
reviewed #426867. Learned a few things, updated the spec file. And now I really
need a sponsor :-)

New URL:s!
 
SRPM: http://hem.bredband.net/miko22/freemind-0.9.0-2.fc8.src.rpm
Spec: http://hem.bredband.net/miko22/freemind.spec
Comment 3 Mamoru TASAKA 2008-01-14 13:48:00 EST
It may be that I will check this package later. But before that
would you fix release number and Requires(post,postun)?

- If this is release candidate (i.e. pre-release), the rpm
  release number "2%{?dist}" is not proper.
  Please check the section "Package Release" of
  http://fedoraproject.org/wiki/Packaging/NamingGuidelines

- For Requires(post/postun), please refer to
  http://fedoraproject.org/wiki/Packaging/ScriptletSnippets

- "env JAVA_HOME=%{java_home} ant" can be substituted with
  %ant macro (defined in %_sysconfdir/rpm/macros.jpackage in
  jpacakage-utils package, which is required by
  java-1.7.0-icedtea and so on)

Comment 4 Mamoru TASAKA 2008-01-14 13:53:19 EST
(In reply to comment #3)
> - "env JAVA_HOME=%{java_home} ant" can be substituted with

s|can be substituted with|can be replaced by|

>   %ant macro (
Comment 5 Alec Leamas 2008-01-14 19:51:32 EST
Made these fixes (+ some others)

New URLs:

Spec: http://hem.bredband.net/miko22/freemind.spec
SRPM:
http://hem.bredband.net/miko22/freemind-0.9.0-0.1.Beta_15_icon_butterfly.src.rpm

Comment 6 Mamoru TASAKA 2008-01-15 01:14:01 EST
(In reply to comment #5)

Rebuild failed.

http://koji.fedoraproject.org/koji/taskinfo?taskID=349310
http://koji.fedoraproject.org/koji/getfile?taskID=349310&name=root.log

This root.log shows that your srpm itself is corrupted.
Also for me "rpm -ivh <your_srpm>" caused
"error: unpacking of archive failed". Would you recheck your srpm itself
and reupload the new one?

BTW IMO the "0.X.Beta15%{?dist}" is enough for release number
(please consider to use dist tag:
 http://fedoraproject.org/wiki/Packaging/DistTag )
Comment 7 Alec Leamas 2008-01-15 06:10:38 EST
Not my day :-(
   - The file seems have been corrupted during transfer, new url below.
   - Added %{?dist}. Keeping long version for time beeing, there has been
     another plain 'Beta_15' floating around upstream until recently. 
     This should  and will be fixed before checking in.
   - Problems with mock. On a clean mock environment, build fails with
     "Bad build req: No Package Found for java-sdk-icedtea". However, 
     "yum whatprovides java-sdk-icedtea" returns
     "java-1.7.0-icedtea-devel.x86_64 : IcedTea Development Environment"
     Don't know how to handle this. Builds in mock environment with icedtea
     devel package installed builds without problem.

URL:s of today:
Spec: http://hem.bredband.net/miko22/freemind.spec
SRPM:
http://hem.bredband.net/miko22/freemind-0.9.0-0.1.Beta_15_icon_butterfly.fc8.src.rpm
Comment 8 Alec Leamas 2008-01-15 07:12:43 EST
Forget the mock issue, resolved after upgrading Alec to 0.2. Note: Alec is still
in a pre-release state... ( I used wrong version argument to mock...)
Comment 9 Mamoru TASAKA 2008-01-15 10:55:45 EST
First of all:

=========================================================================
From spec file - GPLv2+

accessories/marktree.js - MPLv1.1 (not dual with GPL)
accessories/mm2oowriter.xsl - GPLv2 (only)
accessories/tohtml.xsl - MPLv1.1 (not dual with GPL)
accessories/toxhtml.xsl - <same above>

plugins/latex/Readme.txt GPLv3+
==========================================================================

MPLv1.1 is GPLv2 incompatible (perhaps also GPLv3 incompatible)
Also, files under plugins/latex seems GPLv3+.

Setting FE-Legal.
Comment 10 Mamoru TASAKA 2008-01-15 10:58:06 EST
And it seems GPLv2"only" and GPLv3+ is incompatible
Comment 11 Tom "spot" Callaway 2008-01-15 13:49:42 EST
Yeah, you are going to need to get upstream to resolve these license issues. The
MPL 1.1 is not GPLv2 or v3 compatible. Files which are GPLv2 only are not GPLv3
compatible.

As is, this package is not OK for Fedora due to license issues. :/
Comment 12 Mamoru TASAKA 2008-01-16 00:07:40 EST
Note:

In freemind tarball there is lib/forms-1.0.5-src.zip .
However currently Fedora ships jgoodies-forms-1.1.0-2.fc{8,9},
so please consider to use system-wide jgoodies-forms or try to
use recent forms zip file when rebuilding freemind.

Also, freemind contains some pre-compiled .jar or .exe files and
currently I don't know how these pre-compiled files are used
for freemind. Please remove these files and re-compile them from
sources when rebuilding freemind.
Comment 13 Alec Leamas 2008-01-16 04:39:11 EST
Thanks for reviewing. I must say I'm impressed of the process taking place here.
For the moment! I'll see what I can do about the licensing issues. Stay tuned,
but this is likely to take some time...
Comment 14 Alec Leamas 2008-01-19 09:30:29 EST
Updated release 3. Sorry to say, but the review remarks was just the tip of an
iceberg:
- Removed 6 jars, using existing Fedora packages instead (jgoodies-forms is one
of them).
- Rebuild the three  shipped  jars from sources.
- Removing all plugins, and their dependencies on 5(!) different, problematic
licenses (the files mentioned in comment #9 are part of this).
- Some smaller fixes

Swinging the machete this way means to remove all export/import functionality
from Freemind. However, the core functionality create, edit, open & save works
fine, as does the browser applet. Plan to add some plugins later, if/when this
package is approved.

New URL:s: 
Spec: http://hem.bredband.net/miko22/freemind.spec
SRPM: http://hem.bredband.net/miko22/freemind-0.9.0-3.Beta_15.fc8.src.rpm
Comment 15 Mamoru TASAKA 2008-01-19 13:42:19 EST
Well, would you check your srpm itself again?

[tasaka1@localhost freemind]$ LANG=C rpm -ivh freemind-0.9.0-3.Beta_15.fc8.src.rpm 
   1:freemind               warning: user mk does not exist - using root
warning: group mk does not exist - using root
warning: user mk does not exist - using root
warning: group mk does not exist - using root
warning: user mk does not exist - using root( 56%)
warning: group mk does not exist - using root
warning: user mk does not exist - using root
warning: group mk does not exist - using root
########################################### [100%]
error: unpacking of archive failed on file
/home/tasaka1/rpmbuild/SOURCES/jibx_1_0_1.zip;47924469: cpio: read
Comment 16 Alec Leamas 2008-01-20 05:23:05 EST
This is just embarrassing. The size of this file should be 2800848 bytes, and
that's what it is in this very moment. This must not happen again :-(. Sorry to
take your time with such nonsense. 
Comment 17 Mamoru TASAKA 2008-01-20 06:41:33 EST
Umm.. this time actually your srpm has size 2800848 bytes, however 
again it seems broken..
The original freemind-src-0.9.0_Beta_15_icon_butterfly.tar.gz has
12077587 bytes and I doubt that the srpm has the size much smaller than 
this size.

Also, the release number "3" is not proper for pre-release tarball.
Comment 18 Alec Leamas 2008-01-20 07:26:05 EST
Gosh!  The Swedish saying is "en olycka kommer inte ensam" - an accident doesn't
come alone.  Qoute of the day, that is.

Seems that my ISP has some kind of size limitations?! Have uploaded the srpm to
my own machine at
ftp://mumin.dnsalias.net/pub/freemind-0.9.0-3.Beta_15.fc8.src.rpm. Could you
please give it try? Size is  21M (20982628 bytes). 

Comment 19 Mamoru TASAKA 2008-01-21 11:18:18 EST
First of all, when tarball contains some problematic codes,
we requests that you must remove the codes _in advance_ and repackage
the tarball. Please refer to the section  

"When Upstream uses Prohibited Code" of
http://fedoraproject.org/wiki/Packaging/SourceURL
! Please write where the original tarball can be gained in spec file
! And also write how you created your original tarball with
! problematic codes removed.

For 0.9.0-3:

=====================================================================================
Source0: Now okay as GPLv2+ if you remove problematic codes in advance
         and repackage it. 
         (perhaps, expect for some binaries
          written below)

Source1: Public Domain

Source2: Okay as GPLv2+
         (perhaps, except for some binaries
          written below)

Source3: NOT OKAY
         lib/ant/LICENSE.txt - ASLv1.1, GPL incompatible.
         Files under lib/ant must be removed.

Source4: BSD and MIT, okay for GPLv2+.

Source5: BSD, okay for GPLv2+
========================================================================================

* First release number
  - As said above, the release number "-3" is not proper for
    pre-release tarball.
    ref: "Pre-Release packages" of
    http://fedoraproject.org/wiki/Packaging/NamingGuidelines

* Source
  - For Source2, do you have any reason you don't want to use
    released zip file
    http://downloads.sourceforge.net/simplyhtml/shtml_0_12_2_beta1.zip ?
    If so, would you rename Source2 so that it clearly shows
    what day of CVS code you used as tarball?

  - For Source3, please pull codes from CVS as written on
    http://www.xmlpull.org/v1/doc/faq.html#CVS

* Pre-rebuilt binary files
  - Please clean up all pre-built binary files (especially .jar
    files) at %prep like:
---------------------------------------------------------------------
%prep
....
find freemind -name \*.jar -exec rm -f {} ';'
---------------------------------------------------------------------
    to make sure that we are shipping all rebuilt files.

  - There are some other binaries in freemind tarball. 
    I am not sure what they are and also unsure how they are used.
---------------------------------------------------------------------
plugins/help/doc/JavaHelpSearch/DOCS:          data
plugins/help/doc/JavaHelpSearch/DOCS.TAB:      data
plugins/help/doc/JavaHelpSearch/OFFSETS:       data
plugins/help/doc/JavaHelpSearch/POSITIONS:     DBase 3 data file with memo(s)
plugins/help/doc/JavaHelpSearch/TMAP:          data
windows-launcher/Freemind.exe:                 MS-DOS executable PE  for MS
Windows (GUI) Intel 80386 32-bit
windows-launcher/Freemind_light_bulb.exe:      MS-DOS executable PE  for MS
Windows (GUI) Intel 80386 32-bit
---------------------------------------------------------------------
    I guess the last 2 files can be simply ignored, however
    would you tell me for the former 4 files?

  - Also similar files are found under
    src/com/lightdev/app/shtm/help/JavaHelpSearch in shtml.tar.gz
Comment 20 Alec Leamas 2008-01-22 13:14:29 EST
I've encountered a problem which might be a blocking one :-(

The file bindings.jar is the result of a compilation of a xml file which defines
the interface. It might be impossible to get this compilation, involving JAXP
API:s to work. 

When rebuilding  jaxme and running the compiler I run into problems since the
source xml file contains constructs not supported by the jaxme xsd compiler. It
might be possible to walk around this, but I don't know enough about the JAXP 
interfaces to do this, at least not now.

Even worse, current CVS sources shows that freemind now uses Sun's JAXB suite to
handle this. It does support all constructs, but it is at best GPLv2 only. And
it does not build for me, some kind of config problem.

Stay tuned, but once again: this will take some time, and it might very well be
the end of this attempt to get Freemind into Fedora.
Comment 21 Alec Leamas 2008-01-23 10:54:43 EST
My first attempt to submit a package has, for now, failed.

The main reason is that recent code (after 0.0.9Beta15) has became heavy
dependent on Sun's JAXB reference implementation (https://jaxb.dev.java.net).
This code has it's own set of dependencies, and could not reasonable be a part
of this package due to both technical and legal reasons. 

Until 0.9.0 it has been possible to use existing jaxme implementations of these
interfaces. This is not feasible any more.

It might still be possible to use this package if/when the dependencies are in
place. Until that point, this package must be postponed. Looking at these
dependencies, I see no blocking issues. But some work ;-)

Sorry to have wasted your time. For me it has been a lesson, though.
Comment 22 Mamoru TASAKA 2008-01-23 11:09:41 EST
(In reply to comment #21)
> Sorry to have wasted your time. For me it has been a lesson, though.

Don't worry. I apppreciate your work :)
Comment 23 Tom "spot" Callaway 2008-01-23 11:15:32 EST
Indeed, I don't consider it a waste of time. Feel free to come back with another
package. :)
Comment 24 Tarjei Knapstad 2009-05-07 08:38:16 EDT
Could this be reopened? The latest Freemind release candidates (I've tried 0.9.0-RC3 and RC4) work just fine with the OpenJDK VM supplied with Fedora 10 (java-1.6.0-openjdk-1.6.0.0-15.b14.fc10.i386)
Comment 25 Mamoru TASAKA 2009-05-07 08:49:13 EDT
(In reply to comment #24)
> Could this be reopened? The latest Freemind release candidates (I've tried
> 0.9.0-RC3 and RC4) work just fine with the OpenJDK VM supplied with Fedora 10
> (java-1.6.0-openjdk-1.6.0.0-15.b14.fc10.i386)  

Please file a new review request and mark this bug as
a duplicate of the new one.
Comment 26 Jiri Popelka 2010-11-30 05:45:34 EST

*** This bug has been marked as a duplicate of bug 638590 ***
Comment 27 Maurizio 2013-05-27 06:12:27 EDT
some one hijaked my acount so idecide to use another email the problem he is hijaking free maping  my email hijaked is antillon.maurizio@gmail.com


need help to build brigth ideas

Note You need to log in before you can comment on or make changes to this bug.