Bug 428439 - sshd segfaults during kerberos auth with krb4 credentials
sshd segfaults during kerberos auth with krb4 credentials
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pam_krb5 (Show other bugs)
4.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-11 10:38 EST by Adam Stokes
Modified: 2010-10-22 17:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0712
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:55:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pass v4_get_creds correct ctx (384 bytes, patch)
2008-01-11 10:38 EST, Adam Stokes
no flags Details | Diff

  None (edit)
Description Adam Stokes 2008-01-11 10:38:43 EST
Description of problem:
Customer is always getting a segmentation fault whenever trying to authenticate
on  a sshd server with pam_krb5 configured to convert Krb5 credentials to Krb4.
This was a new feature added on request of this very customer with BZ#201265.

An uninitialized variable could be passed down the stack, after a quick chat
with the package maintainer (nalin) I have written the attached patch
"pam_krb5-2.1.17-1.navid_uninit_ctx.diff" which appears to solve the issue for
the customer.

Version-Release number of selected component (if applicable):
pam_krb5-2.1.17

How reproducible:
100%

Steps to Reproduce:
1. on the ssh server, edited /etc/krb5.conf and added:

[appdefaults]
pam = {
 krb4_convert = true
 external = sshd
}

2. on the ssh client, edited /etc/ssh/ssh_config and added:

GSSAPIDelegateCredentials=yes

3. Update pam system-auth to do the krb4 conversion
  
Actual results:
Connection is closed since sshd dies after successful authentication:
ssh(1562) debug1: Authentications that can continue:
publickey,gssapi-with-mic,password
ssh(1562) debug1: Next authentication method: gssapi-with-mic
ssh(1562) debug1: Delegating credentials
ssh(1562) debug1: Delegating credentials
ssh(1562) debug1: Authentication succeeded (gssapi-with-mic).
ssh(1562) debug1: channel 0: new [client-session]
ssh(1562) debug1: Entering interactive session.
ssh(1562) debug1: channel 0: free: client-session, nchannels 1
Connection to refrh4es-i386 closed by remote host.
Connection to refrh4es-i386 closed.
ssh(1562) debug1: Transferred: stdin 0, stdout 0, stderr 89 bytes in 0.2 seconds


Server-side:
debug3: mm_share_sync: Share sync
debug3: mm_share_sync: Share sync end
debug1: temporarily_use_uid: 0/0 (e=0/0)
debug1: restore_uid: 0/0
debug1: PAM: establishing credentials
debug3: PAM: opening session
Segmentation fault (core dumped)

Expected results:
sshd stays alive and authentication succeeds or sshd fails gracefully

Additional info:
Comment 1 Adam Stokes 2008-01-11 10:38:44 EST
Created attachment 291399 [details]
pass v4_get_creds correct ctx
Comment 2 RHEL Product and Program Management 2008-01-11 10:45:42 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2008-07-24 15:55:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0712.html

Note You need to log in before you can comment on or make changes to this bug.