Bug 428440 - Denyhosts fails to start from control script
Denyhosts fails to start from control script
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: denyhosts (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-11 10:45 EST by Matt Castelein
Modified: 2008-01-14 15:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 15:04:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
denyhosts init script (4.04 KB, text/plain)
2008-01-12 12:00 EST, Matt Castelein
no flags Details

  None (edit)
Description Matt Castelein 2008-01-11 10:45:41 EST
Description of problem: Denyhosts fails to start from control script


Version-Release number of selected component (if applicable):
denyhosts-2.6-7.fc8

How reproducible: Always


Steps to Reproduce:
1. Start denyhosts service
2.
3.
  
Actual results:
[root@arturo ~]# service denyhosts start
starting DenyHosts:    /usr/bin/env python /usr/bin/denyhosts.py --daemon
--config=/etc/denyhosts.conf
Could not find environment variable: HOSTNAME


Expected results:
Denyhosts daemon starts

Additional info:

Added os.environ['HOSTNAME'] = "arturo" to /usr/bin/denyhosts-control for
temporary fix.
Comment 1 Jason Tibbitts 2008-01-12 00:03:02 EST
I have to admit I find this odd, because that's not the expected output from the
denyhosts initscript.  First off, can you verify that /etc/init.d/denyhosts
looks like this, down after the initial comment block:

# Make sure HOSTNAME is in the environment so denyhosts can
# use it in report subjects
HOSTNAME=$(hostname)
export HOSTNAME

CRONLOCK=/var/lock/subsys/denyhosts.init
LOCKFILE=/var/lock/subsys/denyhosts

DHOSTS=/usr/bin/denyhosts.py
DOPTS="--daemon --config=/etc/denyhosts.conf"

If so, do you have a /bin/hostname executable?

If so, can you try changing the line:
  HOSTNAME=$(hostname)
in /etc/init.d/denyhosts to 
  HOSTNAME=$(/bin/hostname)
just to rule out the possiility that the initscript is somehow being called with
no PATH defined.
Comment 2 Matt Castelein 2008-01-12 12:00:25 EST
Created attachment 291470 [details]
denyhosts init script
Comment 3 Matt Castelein 2008-01-12 12:01:43 EST
My init script does not match that at all.. I am attaching it so you can have a
look.. I checked to see there were no .rpmnew versions of it as well.
Comment 4 Jason Tibbitts 2008-01-12 21:23:16 EST
Well, it doesn't seem like your problem is actually with denyhosts; it looks
like either something went wrong when the package was installed or something
else is wrong with your system.

Things to try:

rpm -V denyhosts (as root, should give no output)
Make sure that /etc/init.d is a symlink to /etc/rc.d/init.d.

Uninstall and reinstall the denyhosts package.

There was a time before the release of F8 when we shipped a different
initscript; I suppose it's possible that you upgraded but the upgrade went awry
and left you with the old one somehow.
Comment 5 Matt Castelein 2008-01-14 15:04:59 EST
Uninstall and reinstall fixed this issue.  Although the version and arch of the
removed and installed packages were identical, there was a mismatch in size.  My
init script has now been replaced with the working version.  I can only guess
that this happened when I upgraded from fedora 7 to 8.

Note You need to log in before you can comment on or make changes to this bug.