Bug 428443 - nroff: Specifying of any -Txxx option removes all other options
nroff: Specifying of any -Txxx option removes all other options
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: groff (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-11 11:00 EST by Dmitry Butskoy
Modified: 2008-01-29 00:15 EST (History)
0 users

See Also:
Fixed In Version: 1.18.1.4-11.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-27 02:19:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the issue (717 bytes, patch)
2008-01-11 11:00 EST, Dmitry Butskoy
no flags Details | Diff

  None (edit)
Description Dmitry Butskoy 2008-01-11 11:00:20 EST
The latest changes to the nroff(1) script cause it to drop all accumulated
"$opts" when user specifies -Txxx option.

The patch (which fix it) illustrates the issue properly...

I've found this bug, when tried to read a manual page under MC (Midnight
Commander). Due to historical reasons, MC reads any manual through the filter:
"nroff -c -Tlatin1 -mandoc filename". Since it uses "-Tlatin1", in the current
version of nroff all "$opts" will be dropped, IOW no more "-mtty-char -P-c" etc.
As a result, some raw postscript text is shown instead of the properly formatted
manual page.
Comment 1 Dmitry Butskoy 2008-01-11 11:00:20 EST
Created attachment 291400 [details]
Patch to fix the issue
Comment 2 Marcela Mašláňová 2008-01-25 03:15:39 EST
I fixed it in rawhide. Update will be following soon.
Comment 3 Fedora Update System 2008-01-27 02:09:57 EST
groff-1.18.1.4-8.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update groff'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F7/FEDORA-2008-1021
Comment 4 Fedora Update System 2008-01-27 02:19:17 EST
groff-1.18.1.4-11.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2008-01-29 00:15:25 EST
groff-1.18.1.4-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.