Bug 428445 - Installer does not prompt for network information during network-based kickstart.
Installer does not prompt for network information during network-based kickst...
Status: CLOSED DUPLICATE of bug 401531
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
All Linux
low Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-11 11:31 EST by Ray Van Dolson
Modified: 2008-02-19 10:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 10:06:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The screen not present during kickstart installations (83.51 KB, image/png)
2008-01-11 11:31 EST, Ray Van Dolson
no flags Details
Fixes the issue for me. (571 bytes, patch)
2008-01-11 14:49 EST, Ray Van Dolson
no flags Details | Diff

  None (edit)
Description Ray Van Dolson 2008-01-11 11:31:09 EST
Description of problem:
Please note, this is not a duplicate of #401531 :-)

When doing a kickstart installation where the kickstart config is located on a
network resource, the installer does not prompt the installer to supply network
information (hostname, IP, gateway, dns servers etc).  This screen is instead
skipped and the only option for the installer is to either provide the ip
information on the boot command line, hard code it into the kickstart file or
write a script executed in %pre to generate the network information.

Version-Release number of selected component (if applicable):
Anaconda included in RHEL 5.1 installer.

How reproducible:
Every time

Steps to Reproduce:
1. Boot CD #1
2. linux ks=nfs:10.49.6.46:/install/ks/ks-rhel5.cfg
3. Observe system boot, retrieve IP information via DHCP, retrieve kickstart
configuration file (with no %network block in it).
4. Enter into the GUI installer.
5. Observe no network screen is presented to configure network interfaces.
6. Other screens are presented with kickstart defaults intact which can be
overrided by the installer.

Additional info:
I have opened SR 1792462 with RH for this.  The way we use kickstart is as a
"defaults" system with our installers being able to easily override any defaults
defined in the kickstart config.  We would like to see a return to the behavior
of the RHEL4 installer where all anaconda screens are presented to the installer
-- kickstart defaults intact, but able to override them.
Comment 1 Ray Van Dolson 2008-01-11 11:31:09 EST
Created attachment 291401 [details]
The screen not present during kickstart installations
Comment 2 Ray Van Dolson 2008-01-11 11:41:11 EST
Actually it appears that the 'asknetwork' option which I see in Fedora(?) may be
just what we need for this.

I'm not sure if it's available in RHEL 5.1 (will test) -- if not, can we see
this backported?

I have added this request to my SR as well.
Comment 3 Ray Van Dolson 2008-01-11 12:26:52 EST
After testing, the 'asknetwork' option does not appear to trigger the Anaconda
GUI network information screen in either Fedora 8 nor in RHEL 5.1.
Comment 4 Ray Van Dolson 2008-01-11 14:49:57 EST
Created attachment 291413 [details]
Fixes the issue for me.

This patch resolves the issue for me.
Comment 5 Ray Van Dolson 2008-02-19 10:02:42 EST
This appears to be a duplicate of #401531 if someone would be willing to mark it
as such.
Comment 6 Chris Lumens 2008-02-19 10:06:53 EST

*** This bug has been marked as a duplicate of 401531 ***

Note You need to log in before you can comment on or make changes to this bug.