Bug 428466 - nautilus immediately crashes after an update of xorg-x11-server
nautilus immediately crashes after an update of xorg-x11-server
Status: CLOSED DUPLICATE of bug 375131
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-11 15:16 EST by Michal Jaegermann
Modified: 2015-03-03 17:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-25 08:10:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-01-11 15:16:37 EST
Description of problem:

With xorg-x11-server-Xorg-1.4.99.1-0.15.20080107.fc9 and
xorg-x11-drv-ati-6.7.196-6.fc9 in place attempts to start
nautilus end up as follows:

The program 'nautilus' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadName (named color or font does not exist)'.
  (Details: serial 266 error_code 15 request_code 45 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

An output in ~/.xsession-errors starts with 

Xlib:  extension "XEVIE" missing on display ":0.0".

line and no idea if this is somewhat relevant to the problem.

As an aside - I really do not know how to run nautilus
"with the --sync command line option" as it gets started by gnome-session,
I guess, with an impressive array of cryptic command line options.

Version-Release number of selected component (if applicable):
nautilus-2.21.2-1.fc9
xorg-x11-server-Xorg-1.4.99.1-0.15.20080107.fc9
xorg-x11-drv-ati-6.7.196-6.fc9

How reproducible:
always
Comment 1 Michal Jaegermann 2008-01-14 14:32:27 EST
That actually may be another manifestation of bug 375131.
See in particular comment #24 there. With FontPath set to
"built-ins" in xorg.conf nautilus starts again.
Comment 2 Bug Zapper 2008-05-14 00:45:10 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matěj Cepl 2008-06-25 08:10:41 EDT

*** This bug has been marked as a duplicate of 375131 ***

Note You need to log in before you can comment on or make changes to this bug.