Bug 428471 - virsh should use polkit-auth to prompt for PolicyKit credentials
Summary: virsh should use polkit-auth to prompt for PolicyKit credentials
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-11 20:36 UTC by Daniel Berrange
Modified: 2008-08-02 23:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 16:01:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Berrange 2008-01-11 20:36:19 UTC
Description of problem:
virsh currently relies on the user having obtained PolicyKit credentials
externally. In PolicyKit 0.7 there is a new 'polkit-auth' binary is suitable for
being run by command line tools to obtain credentials. If the command line tool
has an X session active it will use the graphical prompt, otherwise it'll do a
text terminal prompt. We should use this, rather than attempting to write
equivalent ourselves.

cf comment #2 on
http://berrange.com/personal/diary/2008/01/policykit-and-libvirt-integration_11

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Berrange 2008-04-04 16:01:31 UTC
Fixed in libvirt-0.4.1-7.fc9


Note You need to log in before you can comment on or make changes to this bug.