Bug 428497 - [workaround possible] OpenOffice.org doesn't launch with livna ati drivers
[workaround possible] OpenOffice.org doesn't launch with livna ati drivers
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
http://www.michaeldemare.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-12 02:09 EST by Michael de Mare
Modified: 2008-01-18 03:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 03:45:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f /usr/lib64/openoffice.org/program/soffice.bin (107.31 KB, text/plain)
2008-01-12 13:01 EST, Michael de Mare
no flags Details
new strace -f ooffice (247.47 KB, text/plain)
2008-01-14 06:15 EST, Michael de Mare
no flags Details
X log in lab (where it works) (44.20 KB, text/plain)
2008-01-16 09:15 EST, Michael de Mare
no flags Details
Xorg.conf (2.08 KB, text/plain)
2008-01-16 09:25 EST, Michael de Mare
no flags Details
compressed Xorg.0.log for home network where OO does NOT work (1.20 MB, application/x-gzip)
2008-01-17 07:14 EST, Michael de Mare
no flags Details

  None (edit)
Description Michael de Mare 2008-01-12 02:09:46 EST
Description of problem:

I installed Fedora 8 on my AMD64 dual-core laptop and installed the updates.  I
try to run openoffice by typing 'ooffice' and it just goes west.  No CPU
activity, no disk activity, it doesn't do anything.

Version-Release number of selected component (if applicable):

latest

How reproducible:

Very

Steps to Reproduce:
1. type 'ooffice'
2.
3.
  
Actual results:

Nothing happens

Expected results:

OpenOffice should start up
Additional info:
Comment 1 Caolan McNamara 2008-01-12 06:25:42 EST
when typing does the ooffice immediately exit, or does it hang there and not exit ?

can you strace -f /usr/lib64/openoffice.org/program/soffice.bin and attach that
output.

Is there is anything known to be unusual about your setup.

Comment 2 Michael de Mare 2008-01-12 13:01:41 EST
Created attachment 291471 [details]
strace -f /usr/lib64/openoffice.org/program/soffice.bin


This is the requested info
Comment 3 Michael de Mare 2008-01-12 13:02:47 EST
Also it just hangs there.  There is no activity on the disk, cpu or network
showing on gkrellm.
Comment 4 Caolan McNamara 2008-01-12 15:34:28 EST
hmm, and does everything else function fine, e.g. no huge delays opening up e.g.
gedit or glxgears ?
Comment 5 Michael de Mare 2008-01-12 17:01:07 EST
Everything else works, except the wireless because I don't have a driver for that.
Comment 6 Caolan McNamara 2008-01-14 04:08:59 EST
I think that basically you're networking/hostname is sort of broken. And a
connection to your localhost is failing due to it.

---broken---

[pid 26708] socket(PF_FILE, SOCK_STREAM, 0) = 6
[pid 26708] connect(6, {sa_family=AF_FILE, path=@/tmp/.X11-unix/X0}, 110) = 0
[pid 26708] getpeername(6, {sa_family=AF_FILE, path=@/tmp/.X11-unix/X0},
[214748364910]) = 0
[pid 26708] uname({sys="Linux", node="localhost.localdomain", ...}) = 0
....
[pid 26708] writev(6, [{"l\0\v\0\0\0\22\0\20\0", 10}, {"\0\0", 2},
{"MIT-MAGIC-COOKIE-1", 18}, {"\0\0", 2},
{"\225.\352\251\204\305&\231\270q@|\366\330\315%", 16}, {"", 0}], 6) = 48
[pid 26708] read(6, 0x60d0d0, 8)        = -1 EAGAIN (Resource temporarily
unavailable)

---not broken---

socket(PF_FILE, SOCK_STREAM, 0)         = 3
connect(3, {sa_family=AF_FILE, path=@/tmp/.X11-unix/X0}, 110) = 0
getpeername(3, {sa_family=AF_FILE, path=@/tmp/.X11-unix/X0}, [110]) = 0
uname({sys="Linux", node="Jehannum", ...}) = 0
....
writev(3, [{"l\0\v\0\0\0\22\0\20\0", 10}, {"\0\0", 2}, {"MIT-MAGIC-COOKIE-1",
18}, {"\0\0", 2}, {"u\223\253jM\261D\265\207\25U\3216\373\347\257", 16}, {"",
0}], 6) = 48
read(3, "\1\0\v\0\0\0E\0", 8)           = 8
Comment 7 Michael de Mare 2008-01-14 05:36:56 EST
Everything else works fine.  This is a fresh Fedora 8 install on a dual core
AMD64 with 2GB of RAM.  I just ran "ssh localhost.localdomain" and it logged in
fine.
Comment 8 Michael de Mare 2008-01-14 06:15:51 EST
Created attachment 291580 [details]
new strace  -f ooffice


I reworked the /etc/hosts file a little so that the hostname gets set correctly
and it still doesn't work.  I attached the new `strace -f ooffice` file.
Comment 9 Michael de Mare 2008-01-15 14:35:37 EST
It works in the lab, but not on my home network.  Everything else works at home
just fine.
Comment 10 Caolan McNamara 2008-01-16 07:42:00 EST
Hmm, what's the X driver at home and at work ? i.e. maybe attaching:
/var/log/Xorg.0.log might help
and does glxgears work ?
Comment 11 Michael de Mare 2008-01-16 09:15:42 EST
Created attachment 291853 [details]
X log in lab (where it works)
Comment 12 Michael de Mare 2008-01-16 09:25:52 EST
Created attachment 291854 [details]
Xorg.conf
Comment 13 Michael de Mare 2008-01-16 09:39:12 EST
I don't know if this helps, but I use both the laptop monitor and an LCD monitor
at home but just the laptop monitor at work.
Comment 14 Michael de Mare 2008-01-16 16:14:48 EST
I can't attach the /var/log/Xorg.0.log from home because the file is too big.
Comment 15 Caolan McNamara 2008-01-17 03:24:34 EST
compress it with e.g. bzip2 or you can mail it directly to me
Comment 16 Michael de Mare 2008-01-17 07:14:46 EST
Created attachment 291987 [details]
compressed Xorg.0.log for home network where OO does NOT work
Comment 17 Caolan McNamara 2008-01-17 07:33:54 EST
Hmm, I think your X driver is screwed: 

http://forums.fedoraforum.org/showthread.php?t=171887

Lets try this: on the broken box edit /usr/lib/openoffice.org/program/soffice
and where it says...

# Uncomment the line below if you suspect that OpenGL is not
# working on your system.
# SAL_NOOPENGL=true; export SAL_NOOPENGL

change it to...

# Uncomment the line below if you suspect that OpenGL is not
# working on your system.
SAL_NOOPENGL=true; export SAL_NOOPENGL

and see does that make a difference
Comment 18 Michael de Mare 2008-01-17 16:25:03 EST
That works!  Thanks.
Comment 19 Caolan McNamara 2008-01-18 03:45:45 EST
Excellent, well we know where the problem lies anyway and have a workaround. 

There's nothing I can do about this through in the general sense as it
reportedly goes away with a different version of the proprietary binary only
video driver. 

I'll close this as "NOTABUG", but I just mean not a bug in OOo which is what we
have to assume unless it can be reproduced with a non-proprietary driver

Note You need to log in before you can comment on or make changes to this bug.