Bug 42851 - No error-report during update with defect RPMs
No error-report during update with defect RPMs
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-30 08:53 EDT by Dirk Traenapp
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-31 23:50:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk Traenapp 2001-05-30 08:53:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en]C-CCK-MCD DT  (WinNT; U)

Description of problem:
I upgraded my RH7.0 from the DVD-ROM and everything went fine without any errorlog. After rebooting the system i found out that KDE was 
defect. "rpm -qa | grep -i kde" found the old package kdelibs. Trying to upgrade kdelibs manually resulted in "md5-error of kdelibs-2.1.1".

This error should have been reported to anaconda too, but where is the errorlog AND much more important a warning-message?

Because of the defect DVD my system is unusuable after the upgrade. Maybe you should implement a consistancy-check before the real 
upgrade. I know that this would be VERY slow. The user should have the choice of checking the CD/DVD before the upgrade-process.

How reproducible:
Always

Steps to Reproduce:
1. Upgrade
2. Reboot
3.
	

Additional info:
Comment 1 Brent Fox 2001-05-31 23:50:46 EDT
We do verify the RPMs before we install them, but depending on how the media is
corrupted, the verification doesn't always fail in the same way.  I think the
DVD issue was due to a manufacturing defect.

Note You need to log in before you can comment on or make changes to this bug.