Bug 428523 - apcupsd don't starts at boot
apcupsd don't starts at boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: apcupsd (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-12 15:48 EST by Roman Danilov
Modified: 2008-01-18 15:01 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 02:38:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Danilov 2008-01-12 15:48:25 EST
Description of problem:

apcupsd don't starts automatically

Version-Release number of selected component (if applicable):

# yum info apcupsd
....
Installed Packages
Name   : apcupsd
Arch   : i386
Version: 3.14.2
Release: 1.fc8
Size   : 1.1 M
Repo   : installed
Summary: APC UPS Power Control Daemon for Linux


How reproducible:


Steps to Reproduce:
1. run "yum install apcupsd"
2. edit /etc/apcupsd/apcupsd.conf for setup your UPS features
3. reboot
4. try "/etc/rc.d/init.d/apcupsd stop" to see that stop fails because it not 
starts at boot
5. try "/etc/rc.d/init.d/apcupsd start" to see that I can manual start it
  
Actual results:


Expected results:


Additional info:

to enable automatic start, do this workaround:

# cd /etc/rc.d/rc5.d
# ln -s ../init.d/apcupsd S99apcupsd
# cd /etc/rc.d/rc3.d
# ln -s ../init.d/apcupsd S99apcupsd
Comment 1 Tomas Smetana 2008-01-14 02:38:01 EST
Yes, there are services that are set off by default and apcupsd is one of them.
 However the init script has proper header so it can be easily turned on using
the chkconfig command.  So please read 'man chkconfig' and then try 'chkconfig
apcupsd on'.  (And remove the symlinks you made.)
Comment 2 Roman Danilov 2008-01-18 15:01:59 EST
(In reply to comment #1)
Thanks, it works fine!
I was removed my symlinks first and do 'chkconfig apcupsd on' as you wrote :-).

Note You need to log in before you can comment on or make changes to this bug.