Bug 428525 - broken autotools in fedora eclipse cdt
broken autotools in fedora eclipse cdt
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-12 15:55 EST by Maciej Sawicki
Modified: 2008-01-14 11:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 11:56:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maciej Sawicki 2008-01-12 15:55:15 EST
when trying to compile simple "hello world" c++ program using "File/New GNU C++ Autotools
Project"

i
getting fallowing error: "
**** Clean-only build of configuration Build (GNU)
for project
okno_zadania
****

make
-k clean 
make: *** No rule to make target `clean'.
Buildfile
generation
error
occurred..
Not
possible to generate Makefile and no existing Makefile
found
Build
stopped.."

my
project
contains one source folder ("zadania") and one cpp
unit (zad1.cpp)
that loks like
this:
"

#include <iostream>

int main (){
	std::cout<<"foo";
	return
0;
}

"
Comment 1 Jeff Johnston 2008-01-14 11:56:27 EST
The error is correct.  You have created the wrong type of project.   You should
have created a simple Managed Make project (no autotools).  You do not have the
files in place for an Autotools project.  An Autotools project is meant to be
used for an existing project that has Autotools files in place (e.g. if you had
checked out the gdb project).  The error is occurring because you do not have a
Makefile in place nor do you have a way of generating a Makefile using
Autotools.  A regular Managed Make project would have created one for you
automatically which is what I believe you meant to do.

For an Autotools project, you are required to provide a configure.in or
configure.ac file that can be input to the autoconf command.  This creates the
configure file used to configure your project.  You also require a Makefile.in
which should be generated from a Makefile.am file using the automake command. 
There are other files, but if you specify --add-missing, they are created for you.

Note You need to log in before you can comment on or make changes to this bug.