Bug 428526 - lyx: error using simplecv.layout, missing simplecv documentclass
lyx: error using simplecv.layout, missing simplecv documentclass
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On: 428686
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-12 16:24 EST by Jonathan Wakely
Modified: 2008-07-31 21:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.5.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-30 13:37:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Wakely 2008-01-12 16:24:07 EST
Description of problem:

the simplecv layout is invalid

Version-Release number of selected component (if applicable):

lyx-1.5.3-1.fc8.x86_64

How reproducible:

Always

Steps to Reproduce:

lyx /usr/share/lyx/examples/simplecv.lyx

 
Actual results:
dialogue pops up with an error, which is also repeated on stderr:

$ lyx  /usr/share/lyx/examples/simplecv.lyx
Warning: Document class not available
----------------------------------------
The layout file requested by this document,
simplecv.layout,
is not usable. This is probably because a LaTeX
class or style file required by it is not
available. See the Customization documentation
for more information.
LyX will not be able to produce output.


Expected results:

simplecv.layout is usable.

Additional info:

This layout used to work with the Fedora 7 version of lyx.
Comment 1 José Matos 2008-01-12 16:37:32 EST
The easiest solution is to package simplecv that is now a latex package 
present at CTAN and require that from lyx. The package is really small so the 
dependency is no problem (previously it was packed with lyx).

From the lyx LaTeXConfig:

CTAN: macros/latex/contrib/simplecv

Notes: The simplecv document class is intended to provide a simple yet elegant 
way to write your curriculum vitae (resume). It is rather minimalist, but has 
nice features like bibliography support (useful for academics). This is a 
repackaging of the cv class that has been available with LyX for a long time. 
The change of name has been made necessary by the existence of another cv 
class on CTAN. An example curriculum vitae created using this document class 
can be found in the examples.
Comment 2 José Matos 2008-01-12 16:38:17 EST
Tomorrow I will try to package this for Fedora.
Comment 3 José Matos 2008-01-14 11:07:25 EST
Done (bug #428686).
Comment 4 Penelope Fudd 2008-02-12 20:35:37 EST
This same error occurs for a *lot* of the templates included with LyX (at least
with Fedora 7).  Are they all fixed for Fedora 8?  Was SimpleCV the only one?

Thanks!
Comment 5 José Matos 2008-02-13 05:55:44 EST
The error reported in this bug is related with a latex template that was part
of the lyx package and that now is packaged separately. In order to allow
users from previous releases to open the documents based on that template
without further installations tex-simplecv was created.

The issue reported in #4 is different (I think) and it has to do with latex
packages that we (Fedora) do not (yet) carry. There are some of those that are
already packaged but you are not there yet for all templates.
Comment 6 Jonathan Wakely 2008-07-21 10:01:07 EDT
I have tex-simplecv installed, how do I work on my CV?  I still get the same error.

Please don't make me use MS Word for my CV!

Comment 7 José Matos 2008-07-21 11:08:26 EDT
What about:
Tools -> Reconfigure
and then restart lyx?

It works here.
Comment 8 Jonathan Wakely 2008-07-26 19:15:30 EDT
Aha, that works :)
This is fixed then - thanks very much.
Comment 9 Fedora Update System 2008-07-30 13:20:35 EDT
lyx-1.5.6-1.fc9 has been submitted as an update for Fedora 9
Comment 10 Fedora Update System 2008-07-30 13:23:11 EDT
lyx-1.5.6-1.fc8 has been submitted as an update for Fedora 8
Comment 11 Fedora Update System 2008-07-31 21:47:01 EDT
lyx-1.5.6-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-07-31 21:48:29 EDT
lyx-1.5.6-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.