Bug 428548 - Package Updater window becomes unresponsive very often
Package Updater window becomes unresponsive very often
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-12 23:05 EST by Praveen A
Modified: 2008-05-28 15:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 15:00:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of unresponsive package updater windows (579.48 KB, image/png)
2008-01-12 23:05 EST, Praveen A
no flags Details

  None (edit)
Description Praveen A 2008-01-12 23:05:23 EST
Description of problem:

Package updater window become unresponsive very often which makes tracking of
the update progress impossible.

Version-Release number of selected component (if applicable):


How reproducible:

When there is a lot of updates available

Steps to Reproduce:
1. Run package updater
2. Move on to other windows
3. Come back to package updater window
  
Actual results:

It does not respond (see attached screenshot)
Expected results:
Progress of update

Additional info:

Is it running with a low priority? I have noticed the same behaviour in two
notebooks.
Comment 1 Praveen A 2008-01-12 23:05:23 EST
Created attachment 291487 [details]
screenshot of unresponsive package updater windows
Comment 2 Jeremy Katz 2008-05-28 15:00:32 EDT
This is because we don't run with threads (because threads + rpmdb access has
some significant downsides and risks of corruption).  gnome-packagekit in Fedora
9 works around this differently.  Not relaly going to make any pirut changes at
this point for it

Note You need to log in before you can comment on or make changes to this bug.