Bug 428550 - XChat fails to close scrollback files, causing it to run out of file handles; patch available
XChat fails to close scrollback files, causing it to run out of file handles;...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
http://xchat.org/files/source/2.8/pat...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-13 00:24 EST by Stephen Clement
Modified: 2008-01-29 00:18 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.8.4-11.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 00:16:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Clement 2008-01-13 00:24:56 EST
Description of problem:
XChat fails to close scrollback files, causing it to eventually run out of file
handles.

Version-Release number of selected component (if applicable):
xchat-2.8.4-6.fc7

How reproducible:
Always, people regularly complain about it in #xchat.

Steps to Reproduce:
1. Have xchat connect to a high volume channel.
2. /usr/sbin/lsof | grep .xchat2/scrollback |wc -l

There is a patch available at
http://xchat.org/files/source/2.8/patches/xc284-fix-scrollbfdleak.diff that
fixes the issue. Please patch and release an update!
Comment 1 Kevin Kofler 2008-01-13 03:15:51 EST
I applied the patch applied in Rawhide already, I'm going to push an XChat with 
the patch to updates-testing.
Comment 2 Kevin Kofler 2008-01-13 03:42:34 EST
Testing update requests submitted for Fedora 7 and 8.
Comment 3 Fedora Update System 2008-01-15 17:54:39 EST
xchat-2.8.4-10.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xchat'
Comment 4 Fedora Update System 2008-01-15 18:03:53 EST
xchat-2.8.4-10.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xchat'
Comment 5 Kevin Kofler 2008-01-17 19:06:58 EST
2.8.4-10 had to be unpushed due to bug 429218 (a regression caused by the 
MIT-SHM pixmap change), I'm pushing a 2.8.4-8 with only the scrollbfdleak patch 
instead.
Comment 6 Kevin Kofler 2008-01-19 01:19:47 EST
Actually, I'll be pushing a 2.8.4-11 with a fix for bug 429218. (2.8.4-8 wasn't 
actually pushed yet and I have 2.8.4-11 now.)
Comment 7 Fedora Update System 2008-01-22 10:48:54 EST
xchat-2.8.4-11.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xchat'
Comment 8 Fedora Update System 2008-01-22 10:50:19 EST
xchat-2.8.4-11.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xchat'
Comment 9 Fedora Update System 2008-01-29 00:16:52 EST
xchat-2.8.4-11.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2008-01-29 00:18:51 EST
xchat-2.8.4-11.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.