Bug 428588 - Support socks proxy
Support socks proxy
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-13 16:37 EST by Kasper Dupont
Modified: 2014-01-21 18:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 11:56:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kasper Dupont 2008-01-13 16:37:31 EST
Feature request

Description of problem:
yum supports http proxies but apparently not socks

Version-Release number of selected component (if applicable):
yum-3.2.8-2.fc8

Additional info:
Sometimes I am in a location where I cannot access the internet directly, but
still have access to ssh to a machine with a direct connection. In such a
situation I can use the -D option for ssh to get a socks proxy that will allow
me to access webpages. But installing updates using yum is not possible because
it only supports http proxies not socks, and the ssh client only implements an
socks proxy not http.
Comment 1 Seth Vidal 2008-03-12 12:30:27 EDT
YUMBUGDAY - anyone have any ideas how to do this?
Comment 2 Seth Vidal 2008-03-13 11:56:37 EDT
okay, so after talking about this a bit. I think it is going to be closed wontfix.

No one here has a socks proxy and debugging this w/o one will be non-trivial. If
you would like to submit a patch to add socks proxy support I'm sure it would be
considered.

Note You need to log in before you can comment on or make changes to this bug.