Bug 428624 - tkinter has broken dependencies
tkinter has broken dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
All Linux
high Severity urgent
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
: 428789 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 04:00 EST by Marcela Mašláňová
Modified: 2008-01-17 11:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 11:00:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2008-01-14 04:00:07 EST
Description of problem:
After rebuild tcl, tk and tix were changed paths according to
http://fedoraproject.org/wiki/PackagingDrafts/Tcl . Tix is now installed
installed into /usr/lib/tcl8.5/libTix.so

Expected results:
Fix paths for tkinter.
Comment 1 Alex Lancaster 2008-01-16 07:54:36 EST
*** Bug 428789 has been marked as a duplicate of this bug. ***
Comment 2 Alex Lancaster 2008-01-16 07:59:09 EST
This causes this broken deps report:

Broken deps for i386
----------------------------------------------------------
	tkinter - 2.5.1-20.fc9.i386 requires libTix8.4.so


(from http://koji.fedoraproject.org/mash/rawhide-20080116/logs/depcheck)

it also prevents scribus and some other packages from being installed (see
duplicate bug #428789).  

What seems to have happened is that tix was rebuilt against new Tcl 8.5, but now
the newly rebuilt tix is not versioned, see:

http://koji.fedoraproject.org/koji/rpminfo?rpmID=353750

note:

Provides  	 libTix.so

in the earlier version of tix there is a version:

http://koji.fedoraproject.org/koji/rpminfo?rpmID=183287

Provides  	 libTix8.4.so

Not sure which needs to be fixed, but either way python probably needs a rebuild.
Comment 3 Marcela Mašláňová 2008-01-16 08:56:08 EST
From guide lines: Tcl and Tk applications must use a non-versioned interpreter
name in shebang line.
The whole guidelines could be found here:
http://fedoraproject.org/wiki/PackagingDrafts/Tcl
Comment 4 Alex Lancaster 2008-01-17 01:36:32 EST
Bumping up priority, this is causing rebuild failures in other rawhide packages,
e.g:

http://koji.fedoraproject.org/koji/buildinfo?buildID=31776
Comment 5 James Antill 2008-01-17 09:26:14 EST
 Tom already tried on the 14th:

http://koji.fedoraproject.org/koji/getfile?taskID=345681&name=build.log

...which gives:

gcc -pthread -shared  Modules/_tkinter.o Modules/tkappinit.o  -ltix -ltk -ltcl
-lX11  -o Modules/_tkinter.so
gcc -pthread -shared  Modules/_cursesmodule.o  -lncursesw  -o
Modules/_cursesmodule.so
gcc -pthread -shared  Modules/_curses_panel.o  -lpanel -lncursesw  -o
Modules/_curses_panel.so
/usr/bin/ld: cannot find -ltix
collect2: ld returned 1 exit status
make: *** [Modules/_tkinter.so] Error 1

...this seems to still be the case now, even though repoquery on rawhide says
/usr/lib64/libtix.so is there. I don't have time to look at this closer until
Monday.
Comment 6 Alex Lancaster 2008-01-17 09:38:32 EST
(In reply to comment #5)
 
> ...this seems to still be the case now, even though repoquery on rawhide says
> /usr/lib64/libtix.so is there. I don't have time to look at this closer until
> Monday.

Can you possibly ask somebody else to help with this (who has commit rights to
the  package)?  This currently blocks building of several other packages such as
system-config-printer (and probably more), as well as installing packages such
as scribus, so it really should be looked at very soon.

Comment 7 James Antill 2008-01-17 10:33:55 EST
 Well my guess was that it wasn't a python problem, so I don't think you'll need
to change anything in python ... just rebuild it once whatever is fixed, and
I'll happily do that. From IRC:

<dgilmore> blarney: looking at it yeah  libTix.so is a symlink to libTix.so

...which would explain the problem.
Comment 8 James Antill 2008-01-17 11:00:40 EST
 And Jesse fixed it.

http://koji.fedoraproject.org/koji/taskinfo?taskID=354903

Note You need to log in before you can comment on or make changes to this bug.