Bug 428658 - Unable to mount samba share using CIFS
Unable to mount samba share using CIFS
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeff Layton
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-01-14 08:34 EST by Paul Mellors
Modified: 2014-06-18 03:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-14 10:10:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg.out file (23.61 KB, text/plain)
2008-01-14 09:21 EST, Paul Mellors
no flags Details

  None (edit)
Description Paul Mellors 2008-01-14 08:34:48 EST
Description of problem:

Unable to mount a samba share on a Debian box from a fedora8 machine using cifs

How reproducible:

Steps to Reproduce:

I tried to mount using the following command, 

mount -t cifs //xx.xx.xx.xx/files /mnt -o user=xxxxx,password=xxxxx
Actual results:

mount: wrong fs type, bad option, bad superblock on //,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

Expected results:

Additional info:

Out put from the dmesg | tail is 

 CIFS VFS: cifs_mount failed w/return code = -22

[root@localhost Desktop]# uname -a
Linux localhost.localdomain #1 SMP Tue Oct 30 13:55:12 EDT 2007
i686 i686 i386 GNU/Linux
Comment 1 Jeff Layton 2008-01-14 08:55:11 EST
It's not clear from your comments, but I assume you're trying to do the CIFS
mount on the F8 box, and the Debian machine is the samba server. What would
probably be most helpful is to turn up cifsFYI and try again. On the client machine:

# modprobe cifs
# echo 7 > /proc/fs/cifs/cifsFYI
# mount -t cifs //xx.xx.xx.xx/files /mnt -o user=xxxxx,password=xxxxx

then, after it fails, do:

# dmesg > /tmp/dmesg.out

...and attach dmesg.out to this case.
Comment 2 Paul Mellors 2008-01-14 09:21:49 EST
Created attachment 291586 [details]
dmesg.out file
Comment 3 Paul Mellors 2008-01-14 09:23:13 EST
sorry for not being clear, yes you're correct i'm trying to connect to a debian
samba server using F8 as the client.  I've attached the dmesg as requested.
Comment 4 Jeff Layton 2008-01-14 09:31:03 EST
Hmm...not much info:

 fs/cifs/cifsfs.c: Devname: // flags: 0 
 fs/cifs/connect.c: CIFS VFS: in cifs_mount as Xid: 3 with uid: 0
 fs/cifs/connect.c: Username: paul
 fs/cifs/connect.c: CIFS VFS: leaving cifs_mount (xid = 3) rc = 0

What version of samba-client do you have on this box? That package contains the
mount.cifs program.

# rpm -q samba-client

...if it's not installed, could you install it and try again?
Comment 5 Paul Mellors 2008-01-14 09:59:44 EST
Hello Jeff

Thanks for that, installing samba-client fixed it, apologies for wasting your
Comment 6 Jeff Layton 2008-01-14 10:10:49 EST
No worries -- glad it was an easy one :-)

Note You need to log in before you can comment on or make changes to this bug.