Bug 428684 - buffer overflow detected while starting kdump service
buffer overflow detected while starting kdump service
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
8
ppc64 All
low Severity high
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
ARRAY(0x8bcb30)
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 10:50 EST by IBM Bug Proxy
Modified: 2009-09-08 23:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.102pre-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-25 19:23:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Script correction (415 bytes, text/plain)
2008-01-14 10:50 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 41346 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-01-14 10:50:20 EST
=Comment: #0=================================================
Mohammed Omar <mohd.omar@in.ibm.com> - 2008-01-01 08:17 EDT
----Problem description:------

Kdump service failed on Fedora 8 on Power5(ppc64) machine. When tried to start
the service ,it throws following messages...

# service kdump start
*** buffer overflow detected ***: /sbin/kexec terminated
======= Backtrace: =========
/lib64/libc.so.6(__fortify_fail-0x8da20)[0x80720ab148]
/lib64/libc.so.6(__chk_fail-0x8fb34)[0x80720a8d14]
/lib64/libc.so.6(__fread_chk-0x8f0c0)[0x80720a9878]
/sbin/kexec[0x1000a434]
/sbin/kexec[0x1000b528]
/sbin/kexec[0x1000374c]
/lib64/libc.so.6[0x8071fbb184]
/lib64/libc.so.6(__libc_start_main-0x175924)[0x8071fbb39c]
======= Memory map: ========
00100000-00103000 r-xp 00100000 00:00 0                                  [vdso]
10000000-10026000 r-xp 00000000 fd:00 3473483                            /sbin/kexec
10035000-10037000 rw-p 00025000 fd:00 3473483                            /sbin/kexec
10037000-1009e000 rw-p 10037000 00:00 0                                  [heap]
8071f20000-8071f4c000 r-xp 00000000 fd:00 13926417                      
/lib64/ld-2.7.so
8071f5f000-8071f60000 r--p 0002f000 fd:00 13926417                      
/lib64/ld-2.7.so
8071f60000-8071f63000 rw-p 00030000 fd:00 13926417                      
/lib64/ld-2.7.so
8071f70000-8072114000 r-xp 00000000 fd:00 13926623                      
/lib64/libc-2.7.so
8072114000-807212c000 ---p 001a4000 fd:00 13926623                      
/lib64/libc-2.7.so
807212c000-8072130000 r--p 001ac000 fd:00 13926623                      
/lib64/libc-2.7.so
8072130000-8072140000 rw-p 001b0000 fd:00 13926623                      
/lib64/libc-2.7.so
8072140000-8072144000 rw-p 8072140000 00:00 0 
8072490000-80724a9000 r-xp 00000000 fd:00 13926490                      
/lib64/libz.so.1.2.3
80724a9000-80724b8000 ---p 00019000 fd:00 13926490                      
/lib64/libz.so.1.2.3
80724b8000-80724ba000 rw-p 00018000 fd:00 13926490                      
/lib64/libz.so.1.2.3
40000000000-40000001000 rw-p 40000000000 00:00 0 
40000020000-40000823000 rw-p 40000020000 00:00 0 
fffffe6c000-fffffe81000 rw-p ffffffeb000 00:00 0                         [stack]
/etc/init.d/kdump: line 151:  5296 Aborted                 $KEXEC $KEXEC_ARGS
$standard_kexec_args --command-line="$KDUMP_COMMANDLINE" --initrd=$kdump_initrd
$kdump_kernel 2> /dev/null
Starting kdump:                                            [FAILED]


-----uname -a--------
Linux p520b.in.ibm.com 2.6.23.1-42.fc8 #1 SMP Tue Oct 30 13:05:49 EDT 2007 ppc64
ppc64 ppc64 GNU/Linux

----Hardware Environment------
    Machine type : p520
    Cpu type : Power5
 
---Is this reproducible?---
YES
---Describe the steps:---
Step 1: Install kernel-kdump-2.6.23.1-42.fc8.ppc64.rpm and
kexec-tools-1.102pre-2.fc8.ppc64.rpm on F8GA on Power5(ppc64) machine.
Step 2: Apply the patch https://bugzilla.linux.ibm.com/attachment.cgi?id=33814
Step 3: Give the command ... service kdump start


---Additional information:----
Latest kexec-tool from upstream
(http://ftp.kernel.org/pub/linux/kernel/people/horms/kexec-tools/testing/kexec-tools-testing-20071017-rc.tar.gz)
is working fine with F8 on ppc64.



Nagesh Sharyathi <sharyathi@in.ibm.com> - 2008-01-14 07:04 EDT
Red Hat team
    This problem is specific to the development rpm shipped with fc8. Instead if
I try to download source rpm and build, the problem is not noticed. So I am of
the view that it is specific to the rpm packaged.
    Please dont forget to aplly the patch I am attaching to this bug. The patch
is from a earlier bug but needs to be applied to recreate this bug
Thanks
Sharyathi
Comment 1 IBM Bug Proxy 2008-01-14 10:50:22 EST
Created attachment 291597 [details]
Script correction
Comment 2 IBM Bug Proxy 2008-01-29 22:25:12 EST
------- Comment From sharyathi@in.ibm.com 2008-01-29 22:16 EDT-------
Distro
Any update on this bug.
Thanks
Comment 3 IBM Bug Proxy 2008-02-05 06:08:32 EST
------- Comment From ssant@in.ibm.com 2008-02-05 06:02 EDT-------
Sharyathi could you please check if a patch from this link fixes this issue ?

http://lists.infradead.org/pipermail/kexec/2008-January/001264.html
Comment 4 IBM Bug Proxy 2008-02-14 03:16:39 EST
------- Comment From sharyathi@in.ibm.com 2008-02-14 03:09 EDT-------
Red Hat
Just to give a heads up, the problem is not getting noticed if you build from
source rpm. The problem is specific to rpm shipped with the distro.
So can you update if this is going to be fixed ? Let us know how to take it
from here.
Thanks
Sharyathi
Comment 5 IBM Bug Proxy 2008-02-14 08:48:38 EST
------- Comment From mohd.omar@in.ibm.com 2008-02-14 08:45 EDT-------
This issue persists in F9Alpha.
F9Alpha has
kernels: 2.6.24-2.fc9
kexec-tools: kexec-tools-1.102pre-3.fc9

--Regards
Omar
Comment 6 Neil Horman 2008-02-14 11:00:04 EST
vivek, do you want me to take this over?  I have a vague recollection of fixing
a buffer overflow in ppc64 in a later version.  Can you try this again with -10.el5?
Comment 7 IBM Bug Proxy 2008-02-15 01:48:31 EST
------- Comment From mohd.omar@in.ibm.com 2008-02-15 01:40 EDT-------
>-10.el5? Is this a version for  a kexec-tool?
If not, Where do I get -10.el5 kernel,kdump-kernel etc...?
Comment 8 Neil Horman 2008-02-19 13:25:27 EST
you can get it on my people page:
http://people.redhat.com/nhorman
I think I just saw this posted upstream, but test with the version on my page,
just to be sure.  Thanks!
Comment 9 Neil Horman 2008-02-20 09:59:36 EST
I just saw this go into the upstream tree:
http://git.kernel.org/?p=linux/kernel/git/horms/kexec-tools-testing.git;a=commit;h=ab2df5cd479da9935e23cd7042d69a39f5cec3b0
I'm guessing thats what we need.  I'll put together a test package for you and
put it on my people page shortly for you to test.  Thanks
Comment 10 Neil Horman 2008-02-20 10:33:24 EST
Ok, kexec-tools pacakge with the upstream patch from comment #9 is available on:
http://people.redhat.com/nhorman
Thanks!
Comment 11 IBM Bug Proxy 2008-02-21 01:16:41 EST
------- Comment From mohd.omar@in.ibm.com 2008-02-21 01:12 EDT-------
Salina/Neil,

I picked up the kexec-tools test rpm from people page ,
http://people.redhat.com/nhorman/rpms/kexec-tools-1.102pre-10.bz428684.el5.ppc64.rpm

It worked properly, didn't throw any buffer overflow messages.
service kdump restart
Stopping kdump:                                            [  OK  ]
Starting kdump:                                            [  OK  ]

--Regards
Omar
Comment 12 Fedora Update System 2008-02-22 09:05:21 EST
kexec-tools-1.102pre-4.fc8 has been submitted as an update for Fedora 8
Comment 13 IBM Bug Proxy 2008-02-25 01:48:37 EST
------- Comment From sharyathi@in.ibm.com 2008-02-25 01:45 EDT-------
Red Hat
Closing from our side
Thanks
Sharyathi
Comment 14 Fedora Update System 2008-02-25 19:23:16 EST
kexec-tools-1.102pre-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.