Bug 428692 - Dependency required for using libvala
Dependency required for using libvala
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vala (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 11:37 EST by Clément DAVID
Modified: 2008-01-18 18:56 EST (History)
0 users

See Also:
Fixed In Version: 0.1.5-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 18:55:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A test case (85 bytes, application/octet-stream)
2008-01-14 11:37 EST, Clément DAVID
no flags Details

  None (edit)
Description Clément DAVID 2008-01-14 11:37:24 EST
Description of problem:
The vala-1.0.vapi file contains references to the Gee namespace but the libgee
is not in the repository. 

libgee [http://freshmeat.net/projects/libgee]
Gee is a library of collection classes, written in Vala. The classes should all
be familiar to users of libraries such as Java's Foundation Classes. Gee
consists of a set of interfaces and various types that implement these in
different ways. Although Gee is not a part of Vala as such, it is used
internally in Vala, and is sufficiently closely related that Vala supports
certain special syntax for Gee related operations.

Version-Release number of selected component (if applicable):
vala-0.1.5-4.fc8

How reproducible:
Try to compile the attached file with :
'/usr/bin/valac --pkg vala-1.0 TestVala.vala'
  
Actual results:
 failed

Expected results:
 compile ;)
Comment 1 Clément DAVID 2008-01-14 11:37:24 EST
Created attachment 291602 [details]
A test case
Comment 2 Michel Alexandre Salim 2008-01-14 12:29:18 EST
Ugh, sounds bad that something that is /not/ part of Vala proper is referenced
in the standard namespace (from the release page it looks like Vala should still
be using its internal copy of libgee). Will check with upstream, thanks.
Comment 3 Michel Alexandre Salim 2008-01-15 10:07:47 EST
I've added the gee-1.0.vapi file to the packaging; this bug entry will be
automatically updated once the test packages hit updates-testing and closed when
it hits the updates repository.

Test case now works, but you need to manually add --pkg gee-1.0 as well.
Comment 4 Michel Alexandre Salim 2008-01-15 10:44:16 EST
Decided to push this straight to the stable 'updates' repository. Meanwhile, you
can rate the package here:

https://admin.fedoraproject.org/updates/F8/pending/vala-0.1.5-5.fc8

and download it:
http://koji.fedoraproject.org/koji/buildinfo?buildID=31655
Comment 5 Fedora Update System 2008-01-18 18:55:55 EST
vala-0.1.5-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-01-18 18:56:41 EST
vala-0.1.5-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.