Bug 428705 - [RHEL5 U2] BUG: unable to handle kernel NULL pointer, EIP is at create_empty_buffers+0x13/0x7d
[RHEL5 U2] BUG: unable to handle kernel NULL pointer, EIP is at create_empty_...
Status: CLOSED DUPLICATE of bug 354461
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
high Severity high
: rc
: ---
Assigned To: LVM and device-mapper development team
Martin Jenner
Depends On:
  Show dependency treegraph
Reported: 2008-01-14 13:52 EST by Jeff Burke
Modified: 2008-01-14 16:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-14 16:54:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-01-14 13:52:08 EST
Description of problem:
While trying to boot the 2.6.18-68.el5 kernel on
dell-pe700-01.rhts.boston.redhat.com The system panics
BUG: unable to handle kernel NULL pointer dereference at virtual address 00000004

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install RHEL5.U1
2. Install the 2.6.18-68.el5 kernel
3. Reboot with the 2.6.18-68.el5 kernel
Actual results:
Setting up Logical Volume Management: BUG: unable to handle kernel NULL pointer
dereference at virtual address 00000004
 printing eip:
*pde = 00000000
Oops: 0000 [#1]
last sysfs file: /block/ram0/dev
Modules linked in: dm_mirror dm_multipath dm_mod video sbs backlight i2c_ec
button battery asus_acpi ac lp joydev i2c_i801 i82875p_edac floppy i2c_core
e1000 parport_pc ide_cd parport edac_mc sg serio_raw i6300esb cdrom pcspkr
ata_piix libata aacraid sd_mod scsi_mod ext3 jbd ehci_hcd ohci_hcd uhci_hcd
CPU:    0
EIP:    0060:[<c04721a8>]    Not tainted VLI
EFLAGS: 00010292   (2.6.18-68.el5 #1) 
EIP is at create_empty_buffers+0x13/0x7d
eax: 00000000   ebx: c16e39a0   ecx: 00000001   edx: 00008000
esi: 00000000   edi: 00000000   ebp: 00000010   esp: f7629d18
ds: 007b   es: 007b   ss: 0068
Process lvm.static (pid: 1352, ti=f7629000 task=f7f88aa0 task.ti=f7629000)
Stack: c16e39a0 c16e39a0 c2f16618 c0474234 f8936628 c0477629 00000000 000201d0 
       c2f16570 00000001 00000001 0000000f 00000001 f88bc044 00008000 000201d0 
       c067be00 c16e39a0 00000000 0ffffffa c16e39a0 c2f16618 00000000 00000000 
Call Trace:
 [<c0474234>] block_read_full_page+0x4b/0x2cd
 [<f8936628>] ide_cdrom_check_media_change_real+0x1a/0x34 [ide_cd]
 [<c0477629>] blkdev_get_block+0x0/0x43
 [<f88bc044>] cdrom_open+0x870/0x8b3 [cdrom]
 [<c04550ee>] add_to_page_cache+0x60/0x70
 [<c045aa48>] __do_page_cache_readahead+0x16d/0x1c6
 [<c047869b>] sys_fstat64+0x1e/0x23
 [<c045aae7>] blockable_page_cache_readahead+0x46/0x99
 [<c045ac7a>] page_cache_readahead+0xb3/0x178
 [<c04555ac>] do_generic_mapping_read+0x137/0x468
 [<c045612b>] __generic_file_aio_read+0x166/0x198
 [<c0454d33>] file_read_actor+0x0/0xd1
 [<c04571b3>] generic_file_read+0x0/0xab
 [<c045724a>] generic_file_read+0x97/0xab
 [<c043628d>] autoremove_wake_function+0x0/0x2d
 [<c0470c50>] vfs_read+0x9f/0x141
 [<c047109e>] sys_read+0x3c/0x63
 [<c0404eff>] syscall_call+0x7/0xb
Code: 74 0a e8 18 ff ff ff e9 62 ff ff ff 31 f6 83 c4 0c 89 f0 5b 5e 5f 5d c3 57
89 cf 56 b9 01 00 00 00 53 89 c3 e8 35 ff ff ff 89 c6 <8b> 50 04 09 38 85 d2 74
04 89 d0 eb f3 89 70 04 8b 43 10 83 c0 
EIP: [<c04721a8>] create_empty_buffers+0x13/0x7d SS:ESP 0068:f7629d18
 <0>Kernel panic - not syncing: Fatal exception

Expected results:
This should boot normally

Additional info:
Comment 1 Milan Broz 2008-01-14 15:07:02 EST
This seems to be problem in cd-rom/ide-cd driver (well, triggered by lvm device
scan) and not any lvm or device-mapper code.
Comment 2 Milan Broz 2008-01-14 15:36:12 EST
Isn't this duplicate of bug 354461 ?
Comment 3 Jeff Burke 2008-01-14 16:54:04 EST
  Yes you are correct. It is a duplicate of 354461

*** This bug has been marked as a duplicate of 354461 ***

Note You need to log in before you can comment on or make changes to this bug.