Bug 42872 - negative package selections in kickstart
Summary: negative package selections in kickstart
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-30 14:39 UTC by Seth Vidal
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 03:54:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Seth Vidal 2001-05-30 14:39:37 UTC
kickstart needs to have the ability to negatively select packages or
package groups.

so something like:
%packages
@ Workstation Common
-@ Emacs

or something like:

%packages
@ Web Server
- tux

that would mean fewer pkg cleanups in %post

thanks

Comment 1 Brent Fox 2001-06-01 03:54:53 UTC
katzj was looking at this.

Comment 2 Jeremy Katz 2001-07-02 22:21:53 UTC
Done for packages in CVS.  Not going to happen for groups because the chances of
causing major problems by excluding a group is much greater.


Note You need to log in before you can comment on or make changes to this bug.