Bug 42875 - DHCP fails to get IP address with Xircom Realport2 card (kernel 2.2.19-7.0.1)
DHCP fails to get IP address with Xircom Realport2 card (kernel 2.2.19-7.0.1)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-30 11:57 EDT by Stephen Torri
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-30 06:21:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Torri 2001-05-30 11:57:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
Xircom Realport2 Cardbus 10/100 Network card fails to get IP address via 
DHCP. When I used kernel version 2.2.16-22 from the fresh install of 
Redhat 7.0 it worked fine. The setup was to use eth0 and the module 
tulib_cb was loaded sucessfully and worked perfectly. So in the effort to 
keep up to date I grabbed the updates for Redhat 7.0. This included the 
kernel rpms (kernel-2.2.19-7.0.1.i686.rpm, kernel-pcmcia-cs-2.2.19-
7.0.1.i386.rpm. and kernel-utils-2.2.19-7.0.1). After upgrading the system 
does not grab an IP address. Either running /etc/init.d/network restart, 
ifconfig eth0 up or pump fails to get an address. 

ifcfg-eth0:


How reproducible:
Always

Steps to Reproduce:
1.Fresh RedHat 7.0 install (uses kernel-2.2.16-22)
2.Upgrade to kernel-2.2.16-22.i686.rpm (using Celeron 400MHz CPU).
3.Execute /etc/init.d/network start
	

Actual Results:  /etc/init.d/network reports:
Bringing up interface eth0: Determining IP information for 
eth0...Operation failed


Expected Results:  /etc/init.d/network reports:
Bringing up interface eth0: [OK]

Additional info:

The only thing that change during was the kernel from 2.2.16-22 to 2.2.19-
7.0.1.

System: 
Twinhead Laptop
Celeron 400MHz
64 MB RAM
Xircom Realport 2 Cardbus 10/100 NIC
pump: ver. 0.8.3-2
dhcpcd: ver. 1.3.18p18-16
initscripts: ver. 5.49-1
Comment 1 Arjan van de Ven 2001-05-30 12:07:15 EDT
You're not the only one with this problem and we're working on a new kernel
rpm with the 2.2.16 driver back in.
In the mean time, does it help if you type:

ifconfig eth0 promisc
pump -i eth0

Comment 2 Arjan van de Ven 2001-06-27 05:12:32 EDT
This is fixed for me in the new 2.2.19 kernel we put out yesterday.
Can you try this new 2.2.19 and see if that fixes it ?
Comment 3 Stephen Torri 2001-06-30 06:21:12 EDT
The driver works fine. I am sending this message with the new kernel. The
only question that I have is how do I determine if I am in full-duplex mode?
The lights tell me I am in 10 or 100 BaseT mode. So I can simply tell which
transfer rate I am using to the hub. The message that the driver prints out is 
very brief compared to the 3Com card I have.
Comment 4 Arjan van de Ven 2001-07-02 04:53:51 EDT
I have no idea. The 2.4 driver I wrote printk's this info to syslog;
but the 2.2 driver is a totally different codebase.

I'm closing this as "fixed in errata" as, well, it is.

Note You need to log in before you can comment on or make changes to this bug.