Bug 428756 - Anaconda mis-computes LVM VG capacity (off by one PE)
Anaconda mis-computes LVM VG capacity (off by one PE)
Status: CLOSED DUPLICATE of bug 437443
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 147544 217222 229090 365491 444384 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 18:02 EST by Carl Roth
Modified: 2008-06-17 17:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-17 17:22:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Roth 2008-01-14 18:02:11 EST
Description of problem:

If I install Fedora onto a system with pre-existing LVs, it computes the total
required size of the VG incorrectly.  Anaconda thinks that the VG requires one
more PE than than the sum of all of the LVs.

I've seen this both on re-imaged disks from FC6 systems, and also on blank disk
images under qemu, set up ahead of time with the F8 rescue CD.

This is a long-standing bug that has appeared in different Fedora and RHEL
releases.  Please forgive me for re-opening this bug again; I'm not sure what
the proper procedure is for collecting together these bugs from different releases:

  BUG147544 (rawhide as of Feb 2005)
  BUG229090 (rawhide as of Feb 2007)
  BUG217913 (RHEL5)

There may be other instances of the bug that I did not notice.

Version-Release number of selected component (if applicable):

Not sure about the anaconda version; it's the anaconda that's baked into the F8
rescue image.

How reproducible:

Always.

Steps to Reproduce:
1. Partition a disk with an LVM volume group.
2. Add LVs to fill up the VG
3. Install Fedora, and point it at the LVs on that disk
  
Actual results:

Anaconda complains that the VG/LV setup is invalid (LVs too large for the VG). 
The spillover amount that it reports is coincidentally the size of one PE.

Expected results:

Anaconda should not complain about the VGs that are set up by a
distro-compatible rescue image.

Additional info:

The workaround (pointed out in one of the other bugs) is pretty easy, provided
that one of the LVs is a swap partition.  Just resize the swap partition to be a
bit smaller, and anaconda will accept the disk layout.
Comment 1 Joel Andres Granados 2008-04-24 12:49:38 EDT
*** Bug 365491 has been marked as a duplicate of this bug. ***
Comment 2 Joel Andres Granados 2008-04-24 12:49:43 EDT
*** Bug 147544 has been marked as a duplicate of this bug. ***
Comment 3 Joel Andres Granados 2008-04-24 12:49:58 EDT
*** Bug 229090 has been marked as a duplicate of this bug. ***
Comment 4 Joel Andres Granados 2008-04-28 06:12:54 EDT
*** Bug 444384 has been marked as a duplicate of this bug. ***
Comment 5 Joel Andres Granados 2008-04-28 06:13:01 EDT
*** Bug 217222 has been marked as a duplicate of this bug. ***
Comment 6 Andy Lindeberg 2008-06-04 10:11:18 EDT
One of the duplicates of this bug is in F9-Alpha, but have you encountered it in
the final release of Fedora 9?
Comment 7 Jerry Amundson 2008-06-04 12:04:51 EDT
(In reply to comment #6)
> One of the duplicates of this bug is in F9-Alpha, but have you encountered it in
> the final release of Fedora 9?

I did not encounter this in my case : Fedora 9 x86_64 - Install DVD, over
previous F8 install with /, swap, and /home in LVs, and /home preserved.
Comment 8 Carl Roth 2008-06-10 10:04:32 EDT
This issue still affects F9 final.  If I start the installer with a
pre-partitioned disk with zero free PVs, then Anaconda reports an error "not
enough space" as soon as I select the first LV.
Comment 9 Andy Lindeberg 2008-06-17 17:22:10 EDT

*** This bug has been marked as a duplicate of 437443 ***

Note You need to log in before you can comment on or make changes to this bug.