Bug 428783 - cannot find module (*-MIB)
cannot find module (*-MIB)
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: zabbix (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 02:03 EST by Dan Horák
Modified: 2008-09-26 08:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-26 08:03:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2008-01-15 02:03:07 EST
Zabbix server prints a group of the following messages into the log

Cannot find module (IP-MIB): At line 0 in (none)
Cannot find module (IF-MIB): At line 0 in (none)
Cannot find module (TCP-MIB): At line 0 in (none)
...

and as a result, it cannot monitor SNMP devices.

net-snmp package needs to be installed too, not only net-snmp-libs which is
autodetected during the build of the package
Comment 1 Jeffrey C. Ollie 2008-01-15 07:43:31 EST
The SNMP MIBs aren't actually _required_.  If the SNMP MIBS are not available
you can still specify SNMP variables as numeric OIDs.  Having the MIBS available
certainly is more convenient.
Comment 2 Dan Horák 2008-09-26 08:03:06 EDT
since net-snmp-5.4.2-2.fc10 are the MIBs in the -libs subpackage instead of the main package

I have seen the dependency on net-snmp (can be removed in Rawhide) in the Jeff's pre 1.6 package, so I am closing this bug.

Note You need to log in before you can comment on or make changes to this bug.