This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 428786 - system-config-network does not read /etc/hosts file...
system-config-network does not read /etc/hosts file...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 03:39 EST by morgan read
Modified: 2008-03-31 06:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 06:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/etc/hosts as per clean install of f8, untouched by me (182 bytes, application/octet-stream)
2008-01-15 15:21 EST, morgan read
no flags Details
/etc/hosts following editing via system-config-network (plus addition of 6s to the IPv6 line) (229 bytes, application/octet-stream)
2008-01-15 15:24 EST, morgan read
no flags Details

  None (edit)
Description morgan read 2008-01-15 03:39:59 EST
Description of problem:
Open system-config-network, choose tab "Hosts", see a blank window

Version-Release number of selected component (if applicable):
system-config-network 1.4.7

How reproducible:
Always

Steps to Reproduce:
1.See Description of problem: above
2.
3.
  
Actual results:
system-config-network shows blank window/tab

Expected results:
system-config-network reports /etc/hosts correctly

Additional info:
Seems the dialogs for adding hosts to /etc/hosts works correctly, just nothing
is reported back.
May be related to this bug: https://bugzilla.redhat.com/show_bug.cgi?id=214932 ?
Comment 1 Jiri Moskovcak 2008-01-15 03:57:03 EST
Could you please post your hosts file?
Comment 2 morgan read 2008-01-15 15:21:21 EST
Created attachment 291737 [details]
/etc/hosts as per clean install of f8, untouched by me
Comment 3 morgan read 2008-01-15 15:24:43 EST
Created attachment 291739 [details]
/etc/hosts following editing via system-config-network (plus addition of 6s to the IPv6 line)
Comment 4 Jiri Moskovcak 2008-01-16 02:41:04 EST
The problem is, that s-c-n doesn't show loopback addresses by default. This is 
not a bug, it's a feature. I made a patch, that makes it possible for user to 
show/hide to loopbacks. I'll add it to s-c-n asap.

Jirka
Comment 5 morgan read 2008-01-16 19:29:44 EST
Hmm, interesting "feature" - but, certainly a switch to show/hide loopbacks
would be a good feature.  Thanks.
M.

Note You need to log in before you can comment on or make changes to this bug.