Bug 428799 - openserdbctl script
openserdbctl script
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openser (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 06:00 EST by Ennio Angeloni
Modified: 2008-02-18 22:15 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.3.0-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 22:14:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
openserdbctl patch to read config from /etc too (1.65 KB, patch)
2008-01-15 07:18 EST, Jan ONDREJ
no flags Details | Diff

  None (edit)
Description Ennio Angeloni 2008-01-15 06:00:11 EST
Description of problem:
path for openserctlrc### include resource files, if any


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
### include resource files, if any
if [ -f /usr/etc/openser//openserctlrc ]; then
if [ -f /usr/etc/openser//openserctlrc ]; then
	. /usr/etc/openser//openserctlrc


Expected results:
### include resource files, if any
if [ -f /etc/openser/openserctlrc ]; then
	. /etc/openser/openserctlrc


Additional info:
Comment 1 Jan ONDREJ 2008-01-15 07:08:27 EST
Where it is present? In my openser-1.3.0-1.fc8 in file /usr/sbin/openserctl
there is this content:

### include resource files, if any
if [ -f /etc/openser/openserctlrc ]; then
        . /etc/openser/openserctlrc
fi
Comment 2 Jan ONDREJ 2008-01-15 07:18:04 EST
Created attachment 291706 [details]
openserdbctl patch to read config from /etc too

I think it is missed in openserdbctl. Already fixed upstream.

Adding a patch from trunk, but may be need more work to apply to openser rpm
package.
Comment 3 Jan ONDREJ 2008-01-22 02:06:17 EST
openser-1.3.0-2.fc7 has been released into updates-testing repository.
Please update your installation and check, if this problem has been fixed.

To update you can use:
  yum update --enablerepo=updates-testing openser\*

This package is not on all mirrors yet. Try after aprox. 5-10 hours.
Comment 4 Fedora Update System 2008-01-22 10:41:10 EST
openser-1.3.0-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openser'
Comment 5 Fedora Update System 2008-01-22 10:47:43 EST
openser-1.3.0-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openser'
Comment 6 Ennio Angeloni 2008-01-24 16:48:40 EST
(In reply to comment #5)
> openser-1.3.0-2.fc8 has been pushed to the Fedora 8 testing repository.  If
problems still persist, please make note of it in this bug report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update openser'

No change on /usr/sbin/openserdbctl
It works only if you run it from
/etc/openser
where the openserctlrc is created by default

OK not a big problem!
Comment 7 Jan ONDREJ 2008-01-25 07:36:13 EST
New openser packages is present in koji:
  http://koji.fedoraproject.org/koji/buildinfo?buildID=32872

openserdbctl works for me. Can you confirm this?

Thank you.
Comment 8 Ennio Angeloni 2008-01-25 11:14:56 EST
openserdbctl works now.

Thank you.
Comment 9 Fedora Update System 2008-01-27 02:20:53 EST
openser-1.3.0-6.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openser'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F8/FEDORA-2008-1074
Comment 10 Ennio Angeloni 2008-01-28 16:57:08 EST
Sorry the URL http://admin.fedoraproject.org/F8/FEDORA-2008-1074 is not working:
   "Sorry! We couldn't find that file"

Report for openserdbctl:
1) path for openserctlrc  is OK
2) looking for /usr/lib/openser/openserctl/openserdbctl.mysql
   but only /usr/lib/openser/openserctl/openserctl.mysql was created
   After making a patch, it seems OK
Comment 11 Jan ONDREJ 2008-01-29 02:02:14 EST
There is openserdbctl.mysql in my openser-mysql package:

[root@Vvoip openserctl]# rpm -qf /usr/lib/openser/openserctl/openserdbctl.mysql 
openser-mysql-1.3.0-6.fc8

Something wrong with your installation?

The URL http://admin.fedoraproject.org/F8/FEDORA-2008-1074 looks to be bodhi bug.
Can you report this in bodhi trac? Right URL is
https://admin.fedoraproject.org/updates/F8/FEDORA-2008-1074 .
Comment 12 Ennio Angeloni 2008-01-29 13:58:15 EST
Updating openser-mysql-1.3.0-6.fc8 my problem is solved.

Sorry, I'm new for bug management: I imagine it needs an account for fedora
project to add comments.
Comment 13 Fedora Update System 2008-02-18 22:14:08 EST
openser-1.3.0-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2008-02-18 22:15:51 EST
openser-1.3.0-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.