Bug 428838 - Update request: conduit-0.3.6
Update request: conduit-0.3.6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: conduit (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
:
Depends On: 429970
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 11:02 EST by Michel Alexandre Salim
Modified: 2008-07-15 08:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.3.11.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-06 02:15:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to conduit spec file (2.57 KB, patch)
2008-01-15 11:41 EST, Michel Alexandre Salim
no flags Details | Diff

  None (edit)
Description Michel Alexandre Salim 2008-01-15 11:02:11 EST
Description of problem:
Conduit has just been updated to 0.3.5:

http://www.johnstowers.co.nz/blog/index.php/2008/01/16/back-to-reality/


Version-Release number of selected component (if applicable):
0.3.4-2

Additional info:
The packaging has changed quite a bit -- upstream's build script is for some
reason putting files *.py* files in %{_libdir} even though the files are not
platform-specific. Will investigate.
Comment 1 Michel Alexandre Salim 2008-01-15 11:41:08 EST
Created attachment 291722 [details]
Patch to conduit spec file

Not sure this is the way to go (overriding %{_libdir} -- but otherwise if the
package is built on 64-bit machines it will install files in a different
location), so I have not patched the remaining shebang-scripts.

Would you be looking for a comaintainer, by any chance? This package looks
really interesting. Thanks.
Comment 2 Bernard Johnson 2008-01-22 22:24:46 EST
I have a build that appears to work, but when I exit, I get:
python: Modules/gcmodule.c:276: visit_decref: Assertion `gc->gc.gc_refs != 0'
failed.
4a8de83b-5090-5b69-3b181b5a-3b235430 is dumped

Is that something you've seen in your build?

I'm reluctant to push any build, even to devel, while this is appearing.  Here
is my build for F-8: http://koji.fedoraproject.org/koji/taskinfo?taskID=366851

If you want to help with the package, request permissions in packagedb and I'll
set you up.
Comment 3 Michel Alexandre Salim 2008-01-23 01:52:16 EST
Mine has the assertion failure, but nothing is dumped:

python: Modules/gcmodule.c:276: visit_decref: Assertion `gc->gc.gc_refs != 0'
failed.

It might be better to wait for 0.4.0 then? That's the next stable version. I've
asked for permission in packagedb, thanks.
Comment 4 Bernard Johnson 2008-01-23 09:27:52 EST
It looks to be a python bug since there is no native code in conduit.  If you
have time, install the python-debuginfo files and get a stacktrace.

Although this doesn't seems to be a conduit bug, I don't want to do any releases
on this until we have a better understanding of the problem.  It would cause a
bunch of bug reports to be filed.
Comment 5 Tim Lauridsen 2008-01-31 08:12:20 EST
Look like there have been released a 0.3.6 version.

http://www.conduit-project.org/wiki/0.3.6

If you guys need somebody to test the package, then just let med know
Comment 6 Bernard Johnson 2008-01-31 14:38:20 EST
The build in comment #2 is 0.3.6 if you want to test drive it.  I'm assuming
you'll run into bug #429970 though which is currently blocking a new release.
Comment 7 Bernard Johnson 2008-01-31 22:07:17 EST
Michel, if I understand your comment on bug #429970, you have tested the build
on rawhide and it does not crash?  If that is so, I'm going to push out a build
to rawhide to get wider testing/feedback.
Comment 8 Michel Alexandre Salim 2008-01-31 23:12:02 EST
I have not tested that particular build -- there does not seem to be any way to
download it. I'm still on my hacked-together 0.3.5, which also suffered from the
assertion failures before I upgraded to Rawhide.

But yes, push it and I'll give it a spin, thanks.
Comment 9 Tim Lauridsen 2008-02-01 05:02:51 EST
I have made a local build for F8 of 0.3.6 located here.

http://timlau.fedorapeople.org/files/test/conduit/

i get the
python: Modules/gcmodule.c:276: visit_decref: Assertion `gc->gc.gc_refs != 0'
failed.

on exit.
I look like the Flickr sync i working in 0.3.6 :)

Comment 10 John Carr 2008-02-01 06:20:46 EST
See #509702 on bgo

http://bugzilla.gnome.org/show_bug.cgi?id=509702
Comment 11 Bernard Johnson 2008-02-01 16:32:27 EST
(In reply to comment #8)
> But yes, push it and I'll give it a spin, thanks.

Here is a rawhide build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=389742

Comment 12 Fedora Update System 2008-02-24 19:25:44 EST
conduit-0.3.8-1.fc8 has been submitted as an update for Fedora 8
Comment 13 Fedora Update System 2008-02-25 19:25:56 EST
conduit-0.3.8-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update conduit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1972
Comment 14 Randall Wood 2008-03-17 10:23:59 EDT
In testing, I'm getting a SEGFAULT:

[Main                ][INFO   ] Conduit v0.3.8 Installed: True (Main.py:79)
[Main                ][INFO   ] Using UI: gtk (Main.py:80)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules (Module.py:103)
[Module              ][DEBUG  ] Reading directory /home/rwood/.conduit/modules
(Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/N800Module (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/BackpackModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/FspotModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/BansheeModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/FlickrModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/ShutterflyModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/NetworkModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/RhythmboxModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/EvolutionModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/SmugMugModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/FileModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/GConfModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/FacebookModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/GmailModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/FeedModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/BoxDotNetModule (Module.py:103)
[Module              ][DEBUG  ] Reading directory
/usr/lib/python2.5/site-packages/conduit/modules/GoogleModule (Module.py:103)
[dataproviders.SimpleFactory][INFO   ] HAL Initialized (VolumeFactory.py:25)
[dataproviders.SimpleFactory][INFO   ] HAL Initialized (VolumeFactory.py:25)
[Utils               ][DEBUG  ] Adding
/usr/lib/python2.5/site-packages/conduit/modules/BackpackModule/backpack to
python path (Utils.py:117)
python: Modules/gcmodule.c:276: visit_decref: Assertion `gc->gc.gc_refs != 0'
failed.
/usr/lib/firefox-2.0.0.12/run-mozilla.sh: line 131:  6242 Segmentation fault   
  "$prog" ${1+"$@"}
Comment 15 John Carr 2008-03-17 16:02:19 EDT
Can someone confirm whether or not this is:
http://bugzilla.gnome.org/show_bug.cgi?id=509702

There is a test case in 
http://bugzilla.gnome.org/show_bug.cgi?id=509702#c28

If that causes the crash, then the bug is in your python gnomevfs bindings. (As
this has not been reported on anything but RH/Fedora and PLD Linux...)
Comment 16 Bernard Johnson 2008-03-27 21:11:18 EDT
Tried the test case you referenced on a fully updated F8:

[bjohnson@localhost ~]$ python
Python 2.5.1 (r251:54863, Oct 30 2007, 13:54:11) 
[GCC 4.1.2 20070925 (Red Hat 4.1.2-33)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> def _(*args, **kwargs):
...     pass
... 
>>> import gnomevfs
>>> t1 = gnomevfs.VolumeMonitor()
>>> t1.connect("volume-mounted",_)
1L
>>> t2 = gnomevfs.VolumeMonitor()
>>> t2.connect("volume-mounted",_)
2L
>>> 
Comment 17 Bernard Johnson 2008-03-27 21:12:36 EDT
Although, when I run it non-interactively:

[bjohnson@localhost tmp]$ python t
python: Modules/gcmodule.c:276: visit_decref: Assertion `gc->gc.gc_refs != 0'
failed.
Aborted
[bjohnson@localhost tmp]$
Comment 18 John Carr 2008-03-28 04:54:51 EDT
So it's a bug in the gnomevfs bindings rather than conduit. Most applications
don't hit this because they only have one volume monitor instance, but because
of our plugins we've ended up with 2 - thus triggering the bug.

The assertion hints that we are allocating something more than once, but only
freeing it once, so the reference count isn't 0 with python is closing.

It seems to only happen on F8/PLD Linux boxes so far, so i don't want to report
it directly GNOME bugzilla...
Comment 19 Bernard Johnson 2008-05-18 21:13:20 EDT
Is gnome-vfs2 the right component for this bug?
Comment 20 Michel Alexandre Salim 2008-06-07 00:35:21 EDT
I have an update to conduit that disables the iPod and N800 modules for now
(enabling any of them trigger the gnome-vfs bug). Also updates the iPod
dependency to python-gpod, not libgpod, and fixes the Firefox detection to be
multilib-aware.
Comment 21 Fedora Update System 2008-06-07 00:52:52 EDT
conduit-0.3.11.1-1.fc9 has been submitted as an update for Fedora 9
Comment 22 Fedora Update System 2008-06-07 00:58:54 EDT
conduit-0.3.11.1-1.fc8 has been submitted as an update for Fedora 8
Comment 23 Fedora Update System 2008-07-06 02:15:23 EDT
conduit-0.3.11.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Fedora Update System 2008-07-15 08:20:22 EDT
conduit-0.3.11.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.