Bug 428865 - multiple definition of `g_bit_nth_lsf' and others while compiling apps with gcc-4.3
Summary: multiple definition of `g_bit_nth_lsf' and others while compiling apps with g...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glib2   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL: https://www.redhat.com/archives/fedor...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-15 18:57 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2008-02-05 17:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 17:27:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2008-01-15 18:57:56 UTC
Description of problem:
Several applications fail to compile with gcc-4.3 due to a problem with glib2
headers.

Version-Release number of selected component (if applicable):
glib2-2.15.0-4.fc9

How reproducible:
Always

Steps to Reproduce:
1. Try rebuilding gxine or ekg2 from rawhide
koji build --scratch --nowait dist-f9-gcc43
cvs://cvs.fedoraproject.org/cvs/pkgs?rpms/ekg2/devel#HEAD
koji build --scratch --nowait dist-f9-gcc43
cvs://cvs.fedoraproject.org/cvs/pkgs?rpms/gxine/devel#HEAD

  
Additional info:
http://sunsite.mff.cuni.cz/rawhide20071220-gcc43/unsorted/ekg2-0.1.1-2.fc9.log
http://sunsite.mff.cuni.cz/rawhide20071220-gcc43/multipledef/gxine-0.5.11-14.fc9.log

Comment 1 Matthias Clasen 2008-02-05 17:27:34 UTC
Is this still a problem ? I assume the inlining changes in 2.15.3 should fix it.
If not, please reopen.


Note You need to log in before you can comment on or make changes to this bug.