Bug 428868 - [PATCH] able to set maxmem lower than current mem allocation
Summary: [PATCH] able to set maxmem lower than current mem allocation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager
Version: 5.3
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 391501 449772
TreeView+ depends on / blocked
 
Reported: 2008-01-15 19:26 UTC by Adam Stokes
Modified: 2009-12-14 21:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:20:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
disallows setting the value of maxmem below current mem value (1.80 KB, patch)
2008-01-15 19:26 UTC, Adam Stokes
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0137 0 normal SHIPPED_LIVE virt-manager enhancement and bug fix update 2009-01-20 16:05:01 UTC

Description Adam Stokes 2008-01-15 19:26:24 UTC
Description of problem:
When editing the gtkspinbutton directly (not using the actual spin buttons) you
are able to apply a max mem value lower than current mem.

Version-Release number of selected component (if applicable):
virt-manager 0.4.0

How reproducible:
100%

Steps to Reproduce:
1. access a shutdown guest in gui
2. access memory tab
3. type a value in the maxmem spinbutton lower than current mem
  
Actual results:
virt-manager allows this setting to be applied

Expected results:
virt-manager should not set the max mem allocation lower than current mem
allocation. it should at least be set the same as current mem or give the
ability to set at a higher value.

Additional info:

Comment 1 Adam Stokes 2008-01-15 19:26:24 UTC
Created attachment 291732 [details]
disallows setting the value of maxmem below current mem value

Comment 2 RHEL Program Management 2008-01-15 19:36:15 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Cole Robinson 2008-03-07 16:14:22 UTC
I've applied this patch upstream:

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=1f1ee216fcef

Might be a bit late for 5.2 since this isn't an intrusive bug, though.

Comment 4 RHEL Program Management 2008-03-11 19:37:01 UTC
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.

Comment 6 RHEL Program Management 2008-06-24 01:32:33 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 7 Cole Robinson 2008-09-15 16:06:31 UTC
Okay, this should be fixed in virt-manager-0.5.3-9.el5. Setting bug to MODIFIED.

Comment 10 errata-xmlrpc 2009-01-20 21:20:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0137.html


Note You need to log in before you can comment on or make changes to this bug.