Bug 428869 - expect build requires libXScrnSaver-devel
expect build requires libXScrnSaver-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: expect (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 14:32 EST by Doug Chapman
Modified: 2008-03-05 09:29 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 09:29:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-01-15 14:32:40 EST
Description of problem:
When building the latest expect it failed with:

/usr/bin/ld: cannot find -lXss


This is part of the libXScrnSaver-devel which needs to be added to the
BuildRequires line so mock knows to pull it in.

thanks,

- Doug



Version-Release number of selected component (if applicable):
expect-5.43.0-11.fc9.src.rpm


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vitezslav Crhonek 2008-01-17 07:58:51 EST
Hi,

There is new version of expect in Rawhide. I can't reproduce this problem with it:

[vcrhonek@norcus devel]$ mock -r fedora-devel-x86_64 expect-5.43.0-12.fc9.src.rpm
INFO: mock.py version 0.8.19 starting...
State Changed: init plugins
State Changed: start
INFO: Start(expect-5.43.0-12.fc9.src.rpm)  Config(fedora-development-x86_64)
State Changed: lock buildroot
State Changed: clean
State Changed: init
State Changed: lock buildroot
INFO: enabled root cache
State Changed: unpacking cache
INFO: enabled yum cache
State Changed: cleaning yum metadata
State Changed: running yum
State Changed: setup
State Changed: build
via send_ttyINFO: Done(expect-5.43.0-12.fc9.src.rpm) Config(fedora-devel-x86_64)
13 minutes 31 seconds
INFO: Results and/or logs in: /var/lib/mock//fedora-development-x86_64/result

BuildRequires are the same in -12 build as they were in -11.
Comment 2 Doug Chapman 2008-01-17 11:21:07 EST
Oddly I still see the error when I build on ia64 with
expect-5.43.0-12.fc9.src.rpm.  I will dig deeper to try to figure out why we see
this on ia64 and not x86_64.

Comment 3 Vitezslav Crhonek 2008-03-05 07:34:40 EST
Did you find something?
Comment 4 Doug Chapman 2008-03-05 09:29:38 EST
Vitezslav,

Thanks for the ping as I had not gotten back to this issue.  I have a large
number of open bugs I am working in the process of getting Fedora-ia64 going.

I just looked at our ia64 koji server and -13 built cleanly so I am just going
to close this issue. 

thanks,

- Doug

Note You need to log in before you can comment on or make changes to this bug.