Bug 428876 - plplot should depend on numpy
plplot should depend on numpy
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: plplot (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 15:29 EST by Cristian Ciupitu
Modified: 2009-03-26 15:01 EDT (History)
1 user (show)

See Also:
Fixed In Version: plplot-5.8.0-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 19:23:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cristian Ciupitu 2008-01-15 15:29:21 EST
Install plplot like this:
# yum install plplot
......
=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 plplot                  i386       5.8.0-1.fc8      updates           2.9 M
Installing for dependencies:
 lasi                    i386       1.0.6-1.fc6      fedora             36 k
 libgfortran             i386       4.1.2-33         fedora            230 k
 plplot-libs             i386       5.8.0-1.fc8      updates           235 k
 qhull                   i386       2003.1-8.fc8     fedora            380 k
 tcl                     i386       1:8.4.15-5.fc8   fedora            1.8 M
 tk                      i386       1:8.4.15-5.fc8   fedora            1.2 M

   
   Then try to use it like this:
>>> import plplot
ImportError: No module named numpy.core.multiarray
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/plplot.py", line 20, in <module>
    from plplotc import *
  File "/usr/lib/python2.5/site-packages/plplotc.py", line 7, in <module>
    import _plplotc
ImportError: numpy.core.multiarray failed to import

  After numpy-1.0.3.1-1.fc8 is installed, the module can be imported without any
(visible) errors.
Comment 1 Fedora Update System 2008-01-22 10:32:48 EST
plplot-5.8.0-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update plplot'
Comment 2 Fedora Update System 2008-02-28 16:40:38 EST
plplot-5.8.0-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Amanda Carter 2009-03-26 15:01:06 EDT
*** Bug 239699 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.