Bug 428879 - Libvirt lacks xml escaping for xm config parsing
Libvirt lacks xml escaping for xm config parsing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks: 449772
  Show dependency treegraph
 
Reported: 2008-01-15 15:41 EST by Cole Robinson
Modified: 2009-12-14 16:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:22:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2008-01-15 15:41:05 EST
If you manually edit an xm config file to add a disk path containing the '&'
character, virt-manager and virtinst start dumping lots of errors like:

Entity: line 14: parser error : xmlParseEntityRef: no name
      <source file='/var/lib/xen/images/test&.img'/>
                                             ^

Since 'xm create' works fine with this config file and an '&' is a valid
character to have in a path, this seems like a bug.

See also bz 428209 for a similar bug.

# rpm -q libvirt
libvirt-0.3.3-4.el5
Comment 2 Daniel Veillard 2008-05-23 07:57:48 EDT
Still current, trivial to reproduce:

[root@test2 ~]# grep test /etc/xen/migr5 
disk = [ "tap:aio:/virt/migr5&test,xvda,w" ]
[root@test2 ~]#  virsh dumpxml migr5 | grep source
      <source file='/virt/migr5&test'/>
      <source bridge='xenbr0'/>
[root@test2 ~]#

  we need to XML escape path strings in the xm driver. This should not be
too hard, assuming it's not fixed already upstream.

Daniel
Comment 5 RHEL Product and Program Management 2008-06-02 16:24:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Daniel Veillard 2008-06-20 10:33:31 EDT
Okay I have built a version libvirt-0.3.3-9.el5 in dist-5E-qu-candidate
with the fix,

Daniel
Comment 9 errata-xmlrpc 2009-01-20 16:22:16 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0142.html

Note You need to log in before you can comment on or make changes to this bug.