Bug 42890 - users command still shows users who have logged off
Summary: users command still shows users who have logged off
Status: CLOSED DUPLICATE of bug 42572
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rsh   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-30 17:22 UTC by Mark Cuss
Modified: 2015-03-05 01:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-31 07:35:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Cuss 2001-05-30 17:22:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
On my RedHat 7.1 server, users rexec and rlogin from other machines for 
access.  Once they logout, the users command still reports them as logged 
in.  RedHat 7 did not do this......

How reproducible:
Always

Steps to Reproduce:
1. Have users rlogin or rexec into a RH7.1 machine
2. Type "users" at a command prompt to see that they have logged in
3. Have the user logogg
4. Type "users" again - they will still be logged in
	

Actual Results:  The procedure above shows that users are still logged in 
even though they are not

Expected Results:  The user's name should have been removed from the list 
when they logoff.

Additional info:

This is a Dell Poweredge 1400 Server (dual PIII's @ 1 GHz) but this has 
also happened on my other RH7.1 machines.  This can be annoying if you 
want to remove and add or change a user on the system.  The only way 
to "log them off" to allow root to change their account is to reboot the 
server - not fun!  This upsets the other users :)

Comment 1 Bernhard Rosenkraenzer 2001-05-31 07:35:44 UTC
Looks like rshd doesn't handle utmp correctly.


Comment 2 Phil Knirsch 2001-06-27 11:31:35 UTC
Has been fixed im recent rawhide kernels (2.4.5-xxx). It seems to have been some
/proc proccesses related bug.

Read ya, Phil

*** This bug has been marked as a duplicate of 42572 ***


Note You need to log in before you can comment on or make changes to this bug.