Bug 428906 - volume not saved on reboot (not restored on boot)
volume not saved on reboot (not restored on boot)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 17:52 EST by Mikel Ward
Modified: 2008-09-09 18:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 18:38:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/alsa/asound.state after setting master volume to 40% (3.67 KB, text/plain)
2008-01-15 17:55 EST, Mikel Ward
no flags Details
/etc/alsa/asound.state after setting master volume to 100% (3.67 KB, text/plain)
2008-01-15 17:55 EST, Mikel Ward
no flags Details

  None (edit)
Description Mikel Ward 2008-01-15 17:52:32 EST
If I set my master volume to 50% then reboot, my master volume is 100% when I
log back in.

It turns out /etc/alsa/asound.state doesn't change when I set the master volume
and store the current state.
Comment 1 Mikel Ward 2008-01-15 17:53:41 EST
Change component from initscripts to alsa-utils.  At first I thought it was due
to /sbin/salsa being called so late in S01reboot, but it now seems it's because
alsactl store isn't doing anything useful.
Comment 2 Mikel Ward 2008-01-15 17:55:04 EST
Created attachment 291762 [details]
/etc/alsa/asound.state after setting master volume to 40%
Comment 3 Mikel Ward 2008-01-15 17:55:38 EST
Created attachment 291763 [details]
/etc/alsa/asound.state after setting master volume to 100%
Comment 4 Mikel Ward 2008-01-15 17:59:49 EST
My master device is described by the GNOME Volume Applet as:
Playback: ALSA PCM: on hw:0 (STAC92xx Analog) via DMA (PulseAudio Mixer)

If I go to File->Change Device, I get the following options:
- HDA Intel (Alsa Mixer)
- SigmaTel STAC9205 (OSS Mixer)
- Playback: ALSA PCM: on hw:0 (STAC92xx Analog) via DMA (PulseAudio Mixer)

Obviously the third of these is selected.

Comment 5 Mikel Ward 2008-01-15 18:11:37 EST
amixer shows the controls/components for the HDA Intel (Alsa Mixer) device when
I use the "controls" command.

$ amixer -c 0 controls
numid=12,iface=MIXER,name='Front Playback Switch'
numid=11,iface=MIXER,name='Front Playback Volume'
numid=6,iface=MIXER,name='Capture Switch'
numid=9,iface=MIXER,name='Capture Switch',index=1
numid=5,iface=MIXER,name='Capture Volume'
numid=8,iface=MIXER,name='Capture Volume',index=1
numid=4,iface=MIXER,name='Analog Loopback'
numid=13,iface=MIXER,name='IEC958 Playback Con Mask'
numid=14,iface=MIXER,name='IEC958 Playback Pro Mask'
numid=15,iface=MIXER,name='IEC958 Playback Default'
numid=16,iface=MIXER,name='IEC958 Playback Switch'
numid=1,iface=MIXER,name='Digital Input Source'
numid=2,iface=MIXER,name='Input Source'
numid=3,iface=MIXER,name='Input Source',index=1
numid=7,iface=MIXER,name='Mux Capture Volume'
numid=10,iface=MIXER,name='Mux Capture Volume',index=1

Changing the card number to 1 or 2 produces an error.

Yet it sets the PulseAudio device (ALSA PCM: on hw:0 (STAC92xx Analog) via DMA
(PulseAudio Mixer)) when I use the "set" command.
$ amixer set Master 50%
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 32768 [50%] [on]
  Front Right: Playback 32768 [50%] [on]
Comment 6 Mikel Ward 2008-01-16 22:52:00 EST
I've been able to work around this by changing the volume control applet to use
device 0: HDA Intel (Alsa mixer).  I also had to change my volume up and down
keys to run "amixer -c 0 cset numid=11 +10%" rather than "amixer set Master
10%+".  It should be obvious this isn't ideal.
Comment 7 Mikel Ward 2008-01-16 23:00:13 EST
That amixer command doesn't actually work.  amixer set Master accepts %
increments (e.g. 10%+ to turn the volume up 10%), but amixer cset doesn't. :-(
Comment 8 Martin Stransky 2008-02-22 06:12:04 EST
It's not going to be handled by alsa anymore...
Comment 9 Lennart Poettering 2008-09-09 18:38:38 EDT
PA now saves and restores audio device volumes automatically in rawhide.

Note You need to log in before you can comment on or make changes to this bug.