Bug 428911 - perl-Glib fails to build on large SMP systems
perl-Glib fails to build on large SMP systems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Glib (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-01-15 18:28 EST by Doug Chapman
Modified: 2008-01-15 18:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 18:34:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-01-15 18:28:05 EST
Description of problem:
It appears that there are some dependency problems in the makefiles for
perl-Glib.  When I build on a really big ia64 system (i.e. more than 48 cpus) it
fails in various ways such as:

make: *** No rule to make target `blib/lib/Glib/ParseXSDoc.pm', needed by
`build/doc.pl'.  Stop.
make: *** Waiting for unfinished jobs....


if I remove the %{?_smp_mflags} (which gives a -j <numcpus> option to make) from
the make line it builds cleanly.

It is slightly (but not a lot since this is a small package) slower without this
but seems it might be simplest just to remove the smp_mflags from the make line
so it builds reliably.

- Doug


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom "spot" Callaway 2008-01-15 18:34:33 EST
Indeed. Committing the change to the devel spec file to drop smp_mflags now.

I'm not going to rebuild this immediately, as I'm in the process of
bootstrapping perl-5.10.0.

Note You need to log in before you can comment on or make changes to this bug.