Bug 428940 - Tooltip help flashes on screen, then disappears
Tooltip help flashes on screen, then disappears
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtkpod (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Todd Zullinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 02:34 EST by Joe Bayes
Modified: 2009-02-04 21:16 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 21:15:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Bayes 2008-01-16 02:34:31 EST
Description of problem:
When I hover my mouse over the buttons near the top of the window ("Load iPod",
etc.), a tooltip window flashes on the screen then disappears perhaps a tenth of
a second later. The tooltip window is not on the screen long enough to read its
contents.

Version-Release number of selected component (if applicable):
gtkpod-0.99.12-1.fc8.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Hover mouse over "Load iPod(s)" button.
  
Actual results:
Tooltip flashes on screen, too fast to read.

Expected results:
Tooltip remains on screen until I move the mouse.
Comment 1 Todd Zullinger 2008-01-20 10:24:59 EST
Hi Joe,

This is known upstream.  It's an issue that affects building with gtk+ 2.12. 
The tooltip API in gtk+ was updated and the older API was deprecated.  AFAIK,
the older API is supposed to still work, but in the case of gtkpod and some
other apps, it doesn't work so well, which results in the flashing tooltips.

The other improvements in gtkpod 0.99.12 seemed worthy enough to warrant the
update even with this known problem.  I will endeavor to get this fixed up
sometime this week if possible.  I know it's annoying.
Comment 2 Todd Zullinger 2008-03-02 21:59:40 EST
I've had no luck in actually fixing this bug.  I have asked for some help on the
gtkpod-devel list and no one there replied. :(

I have filed a bug in the upstream tracker in the hopes that it will get some
attention.

https://sourceforge.net/tracker/index.php?func=detail&aid=1906016&group_id=67873&atid=519273

I have seen a similar problem in a small pygtk app that I wrote, which makes me
think this might be a bug in gtk+ or glib.  But that sadly has not gotten me any
closer to a solution.
Comment 3 Joe Bayes 2008-03-02 23:25:16 EST
Well, thanks for your effort. We out here in user-land appreciate it.
Comment 4 Joe Bayes 2008-05-16 18:13:47 EDT
Bug is still present in Fedora 9, gtkpod-0.99.12-2.fc9.x86_64 .

Comment 5 Todd Zullinger 2008-08-01 11:18:17 EDT
Joe,

This problem seems to have been resolved with a recent update (I believe it was
glib2 or gtk2 that fixed it, but I have not tested to see exactly which update
corrected it).

Can you confirm or deny if the problem is still present in an up to date F9?
Comment 6 Joe Bayes 2008-08-01 12:20:55 EDT
The problem is still present in my up-to-date F9.

gtkpod-0.99.12-2.fc9.x86_64
glib2-2.16.5-1.fc9.x86_64
gtk2-2.12.11-1.fc9.x86_64
Comment 7 Todd Zullinger 2009-01-17 15:44:33 EST
Hey Joe,

Jorg believes he has found and fixed this problem upstream.  It has not been reproducible for me for quite a while, but if it still occurs for you, perhaps you'd like to test some packages with the patch and let me know if it indeed fixes the problem?

I've built updated gtkpod packages for F9 and F10, x86_64 only, as that's what arch you had the problems on.

F-9: http://tmz.fedorapeople.org/tmp/gtkpod-0.99.12-2.fc9.1.x86_64/
F-10: http://tmz.fedorapeople.org/tmp/gtkpod-0.99.12-3.fc10.1.x86_64/

There are SHA1SUM files included.  The SHA1SUM file and packages are signed with my gpg key, 0xBEAF0CE3: http://tmz.fedorapeople.org/repo/RPM-GPG-KEY-tmz

Upstream is set to release 0.99.14 in the next few days, but it might be a bit until we get that and the updated libgpod into the stable releases due to the libgpod changing the API since the last release.  So if this patch does fix things, it'd be good to push it out in the interim.

Thanks, and sorry for the long delay.  (Wow, it's been a year and a day since your initial report.)
Comment 8 Joe Bayes 2009-01-18 12:46:54 EST
Your updated packages fix the problem. Thanks!
Comment 9 Fedora Update System 2009-01-19 01:13:28 EST
gtkpod-0.99.12-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gtkpod-0.99.12-4.fc10
Comment 10 Fedora Update System 2009-01-19 01:13:31 EST
gtkpod-0.99.12-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gtkpod-0.99.12-3.fc9
Comment 11 Todd Zullinger 2009-01-19 01:26:50 EST
Many thanks for testing and feedback Joe.  I've got official updates on the way, for anyone else that's affected by this.
Comment 12 Fedora Update System 2009-01-21 16:26:07 EST
gtkpod-0.99.12-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtkpod'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0708
Comment 13 Fedora Update System 2009-01-21 16:28:18 EST
gtkpod-0.99.12-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update gtkpod'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-0747
Comment 14 Fedora Update System 2009-02-04 21:15:16 EST
gtkpod-0.99.12-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2009-02-04 21:16:18 EST
gtkpod-0.99.12-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.