Bug 428946 - Can not install Fedora Directory Server on Fedora 8 because of unresolved and unresolvable dependencies.
Can not install Fedora Directory Server on Fedora 8 because of unresolved and...
Status: CLOSED NOTABUG
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
7.1
All Linux
low Severity urgent
: ---
: ---
Assigned To: Nathan Kinder
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 05:02 EST by Thomas Schweikle
Modified: 2015-01-04 18:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 17:23:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Schweikle 2008-01-16 05:02:18 EST
Description of problem:
Can not install Fedora Directory Server on Fedora 8 because of unresolved and 
*unresolvable* dependencies.


Version-Release number of selected component (if applicable):
7.1


How reproducible:
always


Steps to Reproduce:
1. Install a minimal Fedora 8
2. Add repositories as described on "http://directory.fedoraproject.org/wiki/
Download"
3. yum install fedora-ds
  
Actual results:
No install, various dependencies are missing:
Error: Missing Dependency: perl(Mozilla::LDAP::Conn) is needed by package 
fedora-ds-admin
Error: Missing Dependency: perl(Mozilla::LDAP::Utils) is needed by package 
fedora-ds-admin
Error: Missing Dependency: perl-Mozilla-LDAP is needed by package fedora-ds-
base
Error: Missing Dependency: perl(Mozilla::LDAP::LDIF) is needed by package 
fedora-ds-base
Error: Missing Dependency: mod_nss is needed by package fedora-ds-admin
Error: Missing Dependency: perl(Mozilla::LDAP::API) is needed by package 
fedora-ds-admin
Error: Missing Dependency: perl(Mozilla::LDAP::API) is needed by package 
fedora-ds-base
Error: Missing Dependency: perl-Mozilla-LDAP is needed by package fedora-ds-
admin
Error: Missing Dependency: perl(Mozilla::LDAP::Conn) is needed by package 
fedora-ds-base
Error: Missing Dependency: jss is needed by package idm-console-framework
Error: Missing Dependency: perl(Mozilla::LDAP::Utils) is needed by package 
fedora-ds-base

Some of them I could resolve manualy, like
- srvcore
- java

Expected results:
seamless installation of *ALL* dependencies --- especially those missing from 
the repositories (!!)

Additional info:
The given set of missing dependencies can't be installed --- there is no 
package available for them!
Comment 1 Nathan Kinder 2008-01-16 12:28:57 EST
The packages that you are unable to resolve are part of the main fedora yum
repositories.  Perhaps your system isn't configured to look for updates in all
of the proper fedora yum repositories?

The packages that it needs to fill the requirements are mod_nss, jss, and
perl-Mozilla-LDAP.
Comment 2 Thomas Schweikle 2008-01-17 17:36:24 EST
Do not think so. In "/etc/yum.repos.d" I have:
-rw-r--r-- 1 root root  306 12. Nov 21:47 dirsrv.repo
-rw-r--r-- 1 root root 1907 12. Dez 22:30 fedora-development.repo
-rw-r--r-- 1 root root   94 15. Jan 16:35 Fedora-install-media.repo
-rw-r--r-- 1 root root 1168 12. Dez 22:30 fedora.repo
-rw-r--r-- 1 root root 1078 12. Dez 22:30 fedora-updates.repo
-rw-r--r-- 1 root root 1151 12. Dez 22:30 fedora-updates-testing.repo
-rw-r--r-- 1 root root  306 12. Nov 21:46 idmcommon.repo

Them holding enabled repositories:
[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$
releasever/Everything/$basearch/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$
releasever&arch=$basearch
*enabled=1*
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-
GPG-KEY

[updates]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/$releasever/
$basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f$
releasever&arch=$basearch
*enabled=1*
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

[dirsrv]
name=Fedora Directory Server - $releasever - $basearch
baseurl=http://directory.fedoraproject.org/yum/dirsrv/fedora/$releasever/$
basearch/RPMS

[dirsrv-noarch]
name=Fedora Directory Server - $releasever - noarch
baseurl=http://directory.fedoraproject.org/yum/dirsrv/fedora/$releasever/noarch/
RPMS

[idmcommon]
name=Fedora IDM Common - $releasever - $basearch
baseurl=http://directory.fedoraproject.org/yum/idmcommon/fedora/$releasever/$
basearch/RPMS

[idmcommon-noarch]
name=Fedora IDM Common - $releasever - noarch
baseurl=http://directory.fedoraproject.org/yum/idmcommon/fedora/$releasever/
noarch/RPMS

Did you realy follow my instructions:
1. Install a minimal Fedora 8 (you'll end up with
   about 128 packages installed)
2. Install yum (is a bit tricky since you have to use rpm)
3. Install yum modules: yum -y install 'yum-*'
   You'll notice some dependencies not solvable.
   Go find the packages by hand, install them, try again.
4. Install needed repositories for the directory server.
5. Do "yum clean all; yum check-update" just to be sure
   the repositories are used.
6. Do "yum install fedora-ds". You'll end up with
   various dependencies not installable because they
   can't resolved. Most of them are resolvable manualy
   searching the repositories. Some you will have difficulties
   because you can not search for them in an easy way. Most of
   the problems are because:
   - dependencies are recorded in the depending package, but
     with a different, old, now unused name.
   - dependencies are recorded in the depending package, but
     asked for with a fixed(!) or lower(!) version number,
     the package isn't available any more with.
   - dependencies are recorded in the depending package, but
     this package just does not exist in any repository, because
     it was canceled months ago in favour of an other package,
     delivering the same or better functionality.
   - dependencies are not recorded at all (you will find them
     being prompted for missing libraries while starting programs).
   - for some reasons in some cases yum interprets same version
     numbers as lower and ignores an existing package.

You are stating packages
- perl-Mozilla-LDAP
- mod_nss
- jss

could you please tell me where these are to be found? In none of the Fedora 8 
repositories are packages named like that or, at least, similar. The packages 
are just missing from the repos.xml file. It is, indeed, in the repository, but 
it won't be found by yum this way! You will have to use

rpm -vhi --nodeps http://.../jss-4.2.5-1.fc8.i386.rpm \
  http://.../perl-Mozilla-LDAP-1.5.2-2.fc8.1.i386.rpm \
  http://.../mod_nss-1.0.7-1.fc8.i386.rpm

to install them. After that you may try again:

yum install fedora-ds

but be avare: it will take another round with rpm until you are successful, 
because various dependencies of above packages are not installed.
Comment 3 Rich Megginson 2008-02-27 23:00:33 EST
I don't understand why yum is not working.  All of these packages are in the
Fedora 8 repos:
http://mirrors.kernel.org/fedora/releases/8/Everything/i386/os/Packages/perl-Mozilla-LDAP-1.5.2-2.fc8.1.i386.rpm
http://mirrors.kernel.org/fedora/releases/8/Everything/i386/os/Packages/mod_nss-1.0.7-1.fc8.i386.rpm
http://mirrors.kernel.org/fedora/releases/8/Everything/i386/os/Packages/jss-4.2.5-1.fc8.i386.rpm

And so are all of their dependencies.  Is it possible this is some sort of
transient error?
Comment 4 Thomas Schweikle 2008-02-28 08:58:00 EST
Yes, they where too as I tried. But: yum does not use these directly. yum looks 
at files in "/fedora/releases/8/Fedora/i386/os/repodata". Sometimes files 
clearly within the repository are not mentioned within these files yum uses. 
yum then states the dependencies broken, even if they are resolvable.

It is a lot like you are looking for a word, say "bird" in "Oxford advanced 
learner's dictionary", but this word isn't inside, even if it exist!

Since this is random and the filenames not entered into one of the files within 
"/fedora/releases/8/Fedora/i386/os/repodata" are random too, I can not help 
with it in any usefull way. What will be broken today if fixed tomorrow --- 
therefor other dependencies might be broken. No regularity, no schema. It looks 
a loot like there are some problems building and mirroring these files on the 
server side.
Comment 5 Rich Megginson 2008-03-10 17:23:20 EDT
I'm going to file this as NOTABUG, or at least not a Fedora DS bug.

Note You need to log in before you can comment on or make changes to this bug.