Bug 428990 - General parse error if k8temp module is loaded
General parse error if k8temp module is loaded
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lm_sensors (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Phil Knirsch
: Rebase
Depends On:
Blocks: RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-01-16 11:52 EST by David Kovalsky
Modified: 2015-03-04 20:19 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
lm_sensors has been re-based to version 2.10.7. This update applies several upstream enhancements and bug fixes, including a fix that prevents libsensors from crashing with a General parse error message when k8temp is also loaded.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:46:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2008-01-16 11:52:52 EST
Unless I blacklist the k8temp module running `sensors' throws out  'General
Parse Error'. I haven't seen this happening on GOLD, since the k8temp module is
new in 5.1.0.


Upstream is well aware of the issue:
...
December 5th, 2006: Note to k8temp users.  The Linux 2.6.19 kernel features a
new hardware monitoring driver, k8temp, which supports all recent AMD K8 CPUs.
The driver will load automatically on supported systems. Due to technical
specificities of this driver, upgrade to lm_sensors 2.10.1 is mandatory. Older
versions of libsensors will fail with a "General parse error" message. If you
can't upgrade lm_sensors for any reason, you'll have to blacklist the k8temp
driver to prevent it from being loaded. Thanks to Artem S. Tashkinov for
notifying us.
...

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-53.1.4.el5.x86_64
lm_sensors-2.10.0-3.1.x86_64
lm_sensors-2.10.0-3.1.i386


How reproducible:
Always

Let me know if you need any information specific to the system. I will also be
happy to test the patched version on my machine.
Comment 1 Tuomo Soini 2008-03-14 11:20:47 EDT
Tested by upgrading to 2.10.1 and it fixed this issue for me.
Comment 2 Phil Knirsch 2008-04-16 10:40:04 EDT
Rebase lm_sensors to 2.10.1 seems necessary due to the kernel changes.

Proposing for RHEL-5.3 and granting Devel ACK as it should be easily doable for
a minor version change.

Read ya, Phil
Comment 5 RHEL Product and Program Management 2008-06-02 16:24:50 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Oli Wade 2008-06-18 10:11:55 EDT
Confirmed still present in 5.2...
Comment 12 Don Domingo 2008-11-12 00:05:36 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
lm_sensors has been re-based to version 2.10.7. This update applies several upstream enhancements and bug fixes, including a fix that prevents libsensors from crashing with a General parse error message when k8temp is also running.
Comment 15 Don Domingo 2008-11-13 19:33:22 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-lm_sensors has been re-based to version 2.10.7. This update applies several upstream enhancements and bug fixes, including a fix that prevents libsensors from crashing with a General parse error message when k8temp is also running.+lm_sensors has been re-based to version 2.10.7. This update applies several upstream enhancements and bug fixes, including a fix that prevents libsensors from crashing with a General parse error message when k8temp is also loaded.
Comment 20 errata-xmlrpc 2009-01-20 15:46:07 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0072.html

Note You need to log in before you can comment on or make changes to this bug.