Bug 428996 - postfix does not havnde >2Gb mailboxes
Summary: postfix does not havnde >2Gb mailboxes
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: postfix   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-16 17:36 UTC by Need Real Name
Modified: 2015-01-12 21:27 UTC (History)
2 users (show)

Fixed In Version: 2.5.6-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 14:27:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2008-01-16 17:36:07 UTC
postfix-2.4.6-2 and earlier does not handle >2Gb mailbox
despite I have
 postconf |grep mailbox_size_limit
mailbox_size_limit = 0
set.

looks this is a problem with postfix itself not being able to handle >2Gb
mailbox files.
All I need is to have local delivery to mailbox working with large files.
Most F8 programs do have proper large file support.

Comment 1 Need Real Name 2008-10-30 17:42:25 UTC
According to postfix author (see a quote of a message from 2005)
http://www.irbs.net/internet/postfix/0507/1398.html
this was a design decision. May be something changed since then.

> >On the contrary.
> >
> >Postfix uses off_t to manipulate file offsets. Only on toy operating
> >systems this is still implemented as a 32-bit type (like only toy
> >operating systems have 16-bit user ID values).
> >
> >Get into the 21st century.
> >
> > Wietse

Comment 2 Miroslav Lichvar 2008-11-20 14:27:28 UTC
Should be fixed in postfix-2.5.5-2.fc11.

Comment 3 Fedora Update System 2008-11-20 14:30:45 UTC
postfix-2.5.5-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/postfix-2.5.5-2.fc10

Comment 4 Fedora Update System 2008-11-20 14:35:11 UTC
postfix-2.5.5-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/postfix-2.5.5-2.fc9

Comment 5 Gilbert Sebenste 2008-11-22 16:53:32 UTC
Can we get this for F8, as it was filed under that?

Comment 6 Fedora Update System 2009-02-25 16:27:24 UTC
postfix-2.5.6-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2009-02-25 16:28:15 UTC
postfix-2.5.6-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.