Bug 429017 - Empty firefox-debuginfo
Empty firefox-debuginfo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 15:07 EST by Ville Skyttä
Modified: 2008-02-20 07:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 07:34:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Symlink xulrunner-stub instead of copying (466 bytes, patch)
2008-02-16 05:08 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2008-01-16 15:07:02 EST
Something in firefox's build prevents useful debuginfo packages from being created:

$ rpm -qlp
http://download.fedora.redhat.com/pub/fedora/linux/development/i386/debug/firefox-debuginfo-3.0-0.beta2.11.nightly20080115.fc9.i386.rpm
(contains no files)

http://fedoraproject.org/wiki/Packaging/Debuginfo
Comment 1 Christopher Aillon 2008-02-15 13:43:32 EST
http://koji.fedoraproject.org/koji/rpminfo?rpmID=418742
Comment 2 Ville Skyttä 2008-02-16 05:07:47 EST
*.debug for the firefox executable is still missing.  If I read the build log
correctly, the executable comes from copying an existing xulrunner-stub from the
xulrunner package to firefox.  xulrunner-stub is already stripped at that point,
and I suppose it'll be somewhat hard to connect its debuginfo to the copy in
this package.

Wouldn't it make more sense to symlink it instead of copying?  Eg. something
like the attached (untested) patch.
Comment 3 Ville Skyttä 2008-02-16 05:08:56 EST
Created attachment 295065 [details]
Symlink xulrunner-stub instead of copying
Comment 4 Martin Stransky 2008-02-19 12:00:28 EST
Just try to install xulrunner+firefox and run firefox from debugger (firefox -g
-d gdb). Works fine for me, the debuginfo is pulled from xulrunner package.
Comment 5 Martin Stransky 2008-02-19 12:37:55 EST
anyway, that xulrunner-stub link is interesting, i'll investigate it (but the
provided patch doesn't seem to work)
Comment 6 Martin Stransky 2008-02-20 07:33:56 EST
Unfortunately, a symlink to xulrunner-stub doesn't work because of broken
xulrunner loader. Anyway, the debuginfo is fine now so i believe this bug can be
closed.

Note You need to log in before you can comment on or make changes to this bug.