This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 429041 - missing dependency
missing dependency
Status: CLOSED DUPLICATE of bug 428847
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 18:03 EST by Steven Pritchard
Modified: 2014-01-21 18:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 15:25:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 511975 None None None Never

  None (edit)
Description Steven Pritchard 2008-01-16 18:03:54 EST
Description of problem:

"yum --enablerepo=development update yum\* rpm\*" on Fedora 8 gives you a broken
yum.  Trying to run it gives the following error:

  There was a problem importing one of the Python modules
  required to run yum. The error leading to this problem was:
  
     /usr/lib64/python2.5/site-packages/_sqlitecache.so: undefined symbol:
g_assertion_message_expr
  
  Please install a package which provides this module, or
  verify that the module is installed correctly.
  
  It's possible that the above module doesn't match the
  current version of Python, which is:
  2.5.1 (r251:54863, Oct 30 2007, 13:45:26) 
  [GCC 4.1.2 20070925 (Red Hat 4.1.2-33)]
  
  If you cannot solve this problem yourself, please go to 
  the yum faq at:
    http://wiki.linux.duke.edu/YumFaq

/usr/lib64/python2.5/site-packages/_sqlitecache.so is owned by
yum-metadata-parser, so I'm assuming it should have a dependency on something in
the newer version of python in rawhide.

Version-Release number of selected component (if applicable):
 rpm                     x86_64     4.4.2.2-12.fc9   development       1.2 M
 rpm-libs                x86_64     4.4.2.2-12.fc9   development       922 k
 rpm-python              x86_64     4.4.2.2-12.fc9   development        65 k
 yum                     noarch     3.2.8-2.fc9      development       509 k
 yum-metadata-parser     x86_64     1.1.2-4.fc9      development        26 k

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 8.
2. yum --enablerepo=development update yum\* rpm\*

Actual results:
Above error.

Expected results:
Working yum.  :-)

Additional info:
Comment 1 Todd Denniston 2008-01-24 09:32:16 EST
This problem still affects yum-metadata-parser-1.1.2-5, at least on i386.

I don't know if this helps tracking down what is broken, but a _work_around_
kludge until yum-metadata-parser is fixed:
pull the _sqlitecache.so (and just that file) from a
yum-metadata-parser-1.1.2-1.fc8.i386.rpm and use it to replace the one installed
by yum-metadata-parser-1.1.2-5.fc9.i386.rpm, and yum works again.
found at:
http://www.fedoraforum.org/forum/showthread.php?t=178870

Comment 2 Seth Vidal 2008-01-24 10:57:18 EST
the problem is glib2 changed the functions it calls without incrementing the
version of the library. So the dependency in yum-metadata-parser has no way of
knowing it needs to be changed. reassigning to the glib maintainers.
Comment 3 Matthias Clasen 2008-02-05 12:07:32 EST
I don' t know since when it is supported to selectively install development
versions of packages onto older releases. 

Sure, the inaccurate dependency is unfortunate.
Comment 4 seth vidal 2008-02-05 15:25:31 EST

*** This bug has been marked as a duplicate of 428847 ***

Note You need to log in before you can comment on or make changes to this bug.