Bug 429074 - invalid /usr/include/asm/gcc_intrin.h
invalid /usr/include/asm/gcc_intrin.h
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Jarod Wilson
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 21:35 EST by David Cantrell
Modified: 2008-05-21 11:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:06:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL5 version gcc_intrin.h fix, including Kbuild addition (1.73 KB, patch)
2008-02-29 13:28 EST, Jarod Wilson
no flags Details | Diff

  None (edit)
Description David Cantrell 2008-01-16 21:35:30 EST
While trying to build the new dhcpv6 on RHEL 5.1, I hit a problem on ia64 with
the gcc_intrin.h header file in /usr/include/asm.  The problem is an invalid
__attribute_used__.  Removing it seemed to work for me:

--- gcc_intrin.h.orig	2007-10-10 17:23:42.000000000 -0400
+++ gcc_intrin.h	2008-01-16 21:33:16.000000000 -0500
@@ -23,7 +23,7 @@
 extern void ia64_bad_param_for_setreg (void);
 extern void ia64_bad_param_for_getreg (void);
 
-register unsigned long ia64_r13 asm ("r13") __attribute_used__;
+register unsigned long ia64_r13 asm ("r13");
 
 #define __ia64_setreg(regnum, val)						\
 ({										\
Comment 1 David Cantrell 2008-01-16 21:36:25 EST
I know it's late in the game, but can this be fixed for 5.2 so I can build the
new dhcpv6 correctly?  Or should I find another way around this problem for 5.2?

Thanks.
Comment 2 Kevin Krafthefer 2008-01-29 14:26:44 EST
pm-ack
Comment 4 David Woodhouse 2008-02-29 11:19:23 EST
That patch is better, because it hides the global register variable altogether.
We really don't want that in userspace. But it's also incomplete -- it should
move gcc_intrin.h to 'unifdef-y' in the Kbuild file, since it now has __KERNEL__
bits to be removed.
Comment 5 Jarod Wilson 2008-02-29 11:32:24 EST
Adding the author of the upstream patch to the cc list.

Doug, do you want to follow up on the additional fix suggested in comment #4?
Comment 6 Doug Chapman 2008-02-29 12:07:59 EST
OK, so _that_ is what unifdef is for (I still feel like a newbie from time to
time).  I guess I didn't know how that stuff worked before but I see what is
needed now.

I will post a patch upstream.

Comment 7 Jarod Wilson 2008-02-29 13:28:03 EST
Created attachment 296400 [details]
RHEL5 version gcc_intrin.h fix, including Kbuild addition
Comment 8 David Woodhouse 2008-02-29 14:06:18 EST
Looks like there's a bunch of other stuff in there which shouldn't be visible in
userspace too -- but maybe we don't want to be changing that for RHEL5. Will
chase upstream.
Comment 11 Don Zickus 2008-03-12 15:41:13 EDT
in kernel-$NEW_VER
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 12 Don Zickus 2008-03-12 15:59:47 EDT
in kernel-2.6.18-85.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 15 errata-xmlrpc 2008-05-21 11:06:50 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.