Bug 429100 - Thunderbird IMAP with Dovecot gives "Invalid Messageset" Error
Thunderbird IMAP with Dovecot gives "Invalid Messageset" Error
Status: CLOSED DUPLICATE of bug 449125
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dovecot (Show other bugs)
All Linux
low Severity low
: rc
: ---
Assigned To: Michal Hlavinka
Depends On:
  Show dependency treegraph
Reported: 2008-01-17 05:33 EST by David Tonhofer
Modified: 2008-09-22 10:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-09-22 10:51:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2008-01-17 05:33:15 EST
Description of problem:

I have been bitten by the problem described in link below, rather quickly after
installation of dovecot I must say. 

I use dovecot and Thunderbird. Thunderbird accesses mail through SSL-ed IMAP.
MTA is postfix. We have mbox format (gonna be changed soon). 

So, at 


we read:

"Though working for a long time, while trying to read their mail, two of our
Thunderbird IMAP users suddenly received the error: "The current command did not
succeed.  The mail server responded: Invalid messageset: -2147483648:*."

A bit of research revealed that Dovecot versions 0.99.13 and earlier have an
interesting bug in which the X-UID header for emails can get too large, and
therefore cannot be processed by Dovecot."

This is difficult to reproduce, but the fix is in. Suppose the user is
"mail-0214", then we just need to filter the X-UID and X-IMAPbase headers out of
the INBOX (or some other affected mbox file), then something similar to this
will help:

cp mail-0214 mail-0214.bak
/etc/rc.d/init.d/dovecot stop
cat mail-0214.bak  | grep -v '^X-UID: ' | grep -v "^X-IMAPbase: " > mail-0214.new
/bin/cp mail-0214.new mail-0214
chmod 600 mail-0214 && chown mail-0214:mail mail-0214
/bin/rm -rf mbox_mail-0214/.imap/INBOX
/etc/rc.d/init.d/dovecot start
Comment 1 David Tonhofer 2008-01-20 16:11:46 EST
Happens often. I will "upgrade" to a self-compiled dovecot-1.0.10 to see whether
that fixes the problem.

Apparently this is more a Thunderbird than a dovecot problem.
Comment 2 Dan Horák 2008-06-10 03:55:54 EDT
Did you the upgrade? We have a workaround in bug #449125, which seems to be
exactly the same problem as you have.
Comment 3 David Tonhofer 2008-09-17 04:31:12 EDT
Yes, the upgrade to dovecot-1.0.10 worked well, no problems encountered. At some point, the machine running this will be upgrade RH4 -> RH5, we will see what the dovecot with RH5 does.
Comment 4 Dan Horák 2008-09-18 03:50:08 EDT
But be careful because since RHEL 5.2 we have dovecot 1.0.7 and I don't think it is possible to go from 1.0.10 back to 1.0.7.
Comment 5 Michal Hlavinka 2008-09-22 10:51:15 EDT

*** This bug has been marked as a duplicate of bug 449125 ***

Note You need to log in before you can comment on or make changes to this bug.