Bug 429111 - xfig pdf/latex export fails
Summary: xfig pdf/latex export fails
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xfig (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Stepan Kasal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-17 13:10 UTC by Bjorge Solli
Modified: 2008-01-18 12:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 12:49:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bjorge Solli 2008-01-17 13:10:35 UTC
Description of problem:
Trying to export to Combined PDF/LaTeX (both parts).
It reports error:
Error during EXPORT.  Messages:
 here pstex_file[0] = 116
 end picture

Happens every time regardless of file.

Version-Release number of selected component (if applicable):
Xfig 3.2 patchlevel 5 (Protocol 3.2)

How reproducible:


Steps to Reproduce:
1. draw easy figure
2. Export ... Combined PDF/LaTeX (both parts)
  
Actual results:
Error during EXPORT.  Messages:
 here pstex_file[0] = 116
 end picture

Expected results:
new file

Additional info:

Comment 1 Bjorge Solli 2008-01-17 13:16:26 UTC
Same error on Fedora 7. Works fine on Fedora 6 where Xfig is at pathch level 4.

Comment 2 Hans de Goede 2008-01-17 16:20:53 UTC
Thanks for reporting this, notice that the error shown is generated by transfig,
not by xfig, but I'm not sure who's fault it is (not yet anyway).

I've tested this and it seems that despite the error an output file does get
generated. Could you please check if that happens for you too and if the output
file is ok (I have no idea what todo with the foo.pdf_t file) ?

I have the feeling that transfig is just showing some debug output and that this
is confusing xfig.


Comment 3 Bjorge Solli 2008-01-18 09:36:58 UTC
The file is not usable, it should also be called name.pdftex_t as it does under
fedora 6 and patch level 4.

Comment 4 Hans de Goede 2008-01-18 12:49:09 UTC
(In reply to comment #3)
> The file is not usable, it should also be called name.pdftex_t as it does under
> fedora 6 and patch level 4.

Okay,

I just checked things with xfig + transfig from FC-6, conclusions:
1) The error dialog is caused by some stray debugging output from transfig
   -> please file a bug against transfig
2) The default filename extension for this export has changed from pdftex_t to
   pdf_t, a behavioral change but not a bug, you can override this in the 
   export dialog if you want
3) The error dialog (which isn't xfig's fault) doesn't mean no export happened,
   and the created file is identical between the FC-6 and F-8 versions, so if 
   its not usable, then it isn't usable in either case.

Conclusion: not an xfig bug, closing.



Note You need to log in before you can comment on or make changes to this bug.